Bug 1118714 - lpf install of flash fails as permissions incorrect
Summary: lpf install of flash fails as permissions incorrect
Keywords:
Status: CLOSED DUPLICATE of bug 1080149
Alias: None
Product: Fedora
Classification: Fedora
Component: lpf
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Alec Leamas
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-11 10:20 UTC by Steve
Modified: 2014-08-30 08:31 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-30 08:31:38 UTC


Attachments (Terms of Use)

Description Steve 2014-07-11 10:20:22 UTC
Description of problem:
lpf install of flash fails as permissions incorrect of output directory

Version-Release number of selected component (if applicable):


How reproducible:
every time

Steps to Reproduce:
1. run lpf-flash-plugin
2. build fails as output directory is blocked for write

Actual results:
build fails as output directory is blocked for write

Expected results:
lpf-flash-plugin should build and install plugin

Additional info:
install error with lpf system
---------------------------------------------------------
cp: cannot create regular file
‘/var/lib/lpf/rpms/flash-plugin/flash-plugin-properties-11.2.202.394-1.fc20.x86_64.rpm’:
Permission denied                                                               
cp: cannot create regular file
‘/var/lib/lpf/rpms/flash-plugin/flash-plugin-11.2.202.394-1.fc20.x86_64.rpm’:
Permission denied      
flash-plugin: build completed  
---------------------------------------------------------
the system worked correctly after applying the following as root
---------------------------------------------------------
cd /var/lib/lpf/rpms/                                                           
chmod g+w -R .
---------------------------------------------------------

Comment 1 Alec Leamas 2014-08-30 08:31:38 UTC
Hm, this seems to be a duplicate. Please let me know if I'm wrong...

*** This bug has been marked as a duplicate of bug 1080149 ***


Note You need to log in before you can comment on or make changes to this bug.