Bug 1118724 - hplip: missing gnupg dependency (required for plugin installation)
Summary: hplip: missing gnupg dependency (required for plugin installation)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: hplip
Version: 20
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-11 11:18 UTC by Seb L.
Modified: 2014-07-26 00:09 UTC (History)
2 users (show)

Fixed In Version: hplip-3.14.6-5.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-26 00:09:29 UTC


Attachments (Terms of Use)

Description Seb L. 2014-07-11 11:18:35 UTC
Description of problem:
When downloading/installing a plugin from hplip, installs fails because of missing "gpg" command.

Version-Release number of selected component (if applicable):
hplip-3.14.6-2.fc20.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Try to install a multi-function printer (in my case a LaserJet 500)
2. The installer requests to download/install a plugin.

Actual results:
Installation fails because of missing gpg command.

Expected results:
Installation should succeed.

Additional info:
The following record is written to syslog:
  hp-plugin: hp-plugin[16470]: error: GPG command not found

Missing gnupg/gnupg2 dependency (in my case, adding a simple symlink from gpg2 to gpg solves the issue).

Comment 1 Fedora Update System 2014-07-21 16:58:12 UTC
hplip-3.14.6-5.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/hplip-3.14.6-5.fc20

Comment 2 Fedora Update System 2014-07-22 03:34:01 UTC
Package hplip-3.14.6-5.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing hplip-3.14.6-5.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-8629/hplip-3.14.6-5.fc20
then log in and leave karma (feedback).

Comment 3 Fedora Update System 2014-07-26 00:09:29 UTC
hplip-3.14.6-5.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.