Bug 1118743 - smart-proxy lifecycle environment ui only works with a single organization
Summary: smart-proxy lifecycle environment ui only works with a single organization
Keywords:
Status: CLOSED DUPLICATE of bug 1103157
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
high
high vote
Target Milestone: Unspecified
Assignee: Walden Raines
QA Contact: Katello QA List
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-11 12:39 UTC by Tom McKay
Modified: 2016-04-22 16:05 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-13 15:13:59 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 6587 None None None 2016-04-22 16:05:53 UTC

Description Tom McKay 2014-07-11 12:39:57 UTC
From foreman-dev email...

As a side note, editing a SP in the UI in org A properly displays just A's lifecycle environments for inclusion. However, switching to B and modifying the SP w/ B's lifecycle environments effectively erases any that were previously associated from A. (I believe there may be an already existing catch-all bug for this since the same behavior exists (existed?) when edit relationships on the org page itself. (ie. If the user did not have permissions to see all templates, when they saved their choices it would erase any previous assocations.)

Comment 1 Tom McKay 2014-07-11 12:39:59 UTC
Created from redmine issue http://projects.theforeman.org/issues/6587

Comment 3 Walden Raines 2014-08-06 04:05:21 UTC
Moving bugs I'm not currently working on back to NEW.

Comment 4 Walden Raines 2014-08-13 15:13:59 UTC
This is a duplicate of #1103157.  The problem here is that you must pass ALL of the IDs or else you unintentionally erase some.

*** This bug has been marked as a duplicate of bug 1103157 ***


Note You need to log in before you can comment on or make changes to this bug.