Bug 111878 - radeonfb module do not work
radeonfb module do not work
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Depends On:
  Show dependency treegraph
Reported: 2003-12-11 01:48 EST by Behdad Esfahbod
Modified: 2015-01-04 17:04 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-11-19 14:28:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Behdad Esfahbod 2003-12-11 01:48:50 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114 Epiphany/1.0.4

Description of problem:
Tested with this kernel in rawhide, and also with a few ones from
Arjan that I have tested in the past, with all, radeonfb module simply
does not work.  Means that 'modprobe radeonfb' do not give me the
framebuffer.  No oopses, no errors, it seems to be loaded, but does
not do anything.  Trying to unload it once crashed my system, never
tried anymore.  With vanilla kernel it works well and gives me a nice
200x75 console.  With Arjan's, once I compiled radeonfb builtin and it
worked, recompiled as a module, and does not.

BTW, with my 2.4, loading radeonfb after X has started make it hang,
so I do not try it after X anymore.  It may be problematic as you
cannot put the modprobe line in rc.local.  Should add it in the very
first lines of rc.sysinit.  Oops, nonsense...

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. init 1
2. modprobe radeonfb

Actual Results:  nothing interesting happens

Expected Results:  a framebuffer console appears

Additional info:
Comment 1 Bernie Innocenti 2004-01-04 15:58:23 EST
I can confirm this bug for 2.6.0-1.109 and 2.6.0-1.23, 
altough I've never tested with a vanilla kernel. 
I build radeonfb into the kernel and pass the following 
command line parameter: 
Used to work fine with earlier 2.5.x kernels. 
Comment 2 Dave Jones 2004-10-29 23:55:22 EDT
still a problem with current kernels ?
Comment 3 Behdad Esfahbod 2004-11-19 14:28:58 EST
Works for me with latest FC2 kernel.  Closing.

Note You need to log in before you can comment on or make changes to this bug.