Bug 1118812 - RHEV-H Installer Fails With Default Partitioning Layout (RHEV Hypervisor - 6.5 - 20140520.0.el6ev and 20140603)
Summary: RHEV-H Installer Fails With Default Partitioning Layout (RHEV Hypervisor - 6....
Keywords:
Status: CLOSED DUPLICATE of bug 1099384
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: rhev-hypervisor
Version: 3.4.0
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
: 3.5.0
Assignee: Ryan Barry
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-11 15:02 UTC by Robert McSwain
Modified: 2019-04-28 09:30 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-06 02:19:37 UTC
oVirt Team: Node


Attachments (Terms of Use)

Description Robert McSwain 2014-07-11 15:02:38 UTC
Description of problem:
Environment
    HP Proliant DL380 G6
    local (direct attached) 68GB drive and 144GB of RAM

By default the installer tries to create a very large swap partition of 88992 MB. When completing the setup *with default options*, the setup fails with:

     Exception: runtime error ('failed to partition/format',)

At this point the only option given is to "reboot" -- there is no option to go back and edit the partitions. Rebooting, running the RHEV-H setup again, modifying the swap partition, and decreasing it to 50,992 MB (for example) completes fine.

Version-Release number of selected component (if applicable):
RHEV Hypervisor - 6.5 - 20140520.0.el6ev and 20140603

How reproducible:
100%

Steps to Reproduce:
1. Attempt to install to a host with a large amount of RAM (works as expected with 8 GB) using the default partitioning layout for swap. 

Actual results:
Installation fails

Expected results:
The default partitioning scheme in RHEV-H setup should work without intervention.

Additional info:
Reducing the RAM to 8GB, I could not reproduce the issue. This it can only be reproduced when the RAM on the box is fairly high, e.g. 144GB in this case.

Comment 1 Fabian Deutsch 2014-07-15 15:12:06 UTC
Ryan, can you please check if this is possibly also addressed with this patch:

u/s Change-Id: I70277cfebbed9646022d2055c9302dbf8fccdf4d
Bug-Url: https://bugzilla.redhat.com/show_bug.cgi?id=1087341

Comment 2 Ryan Barry 2014-07-15 15:24:00 UTC
It does appear to be a duplicate.

I don't think I have any systems with enough memory to reproduce (the biggest I've got here is 48GB), but it does appear to be a duplicate of:

https://bugzilla.redhat.com/show_bug.cgi?id=1087324

(looks like I used the wrong bug in the patch)

I'll see about reproducing

Comment 3 Fabian Deutsch 2014-08-01 10:51:50 UTC
Hey Robert, it looks this bug seems to be caused by the combination of a large amount of RAM and a small disk.
Normally RHEV-H treis to create a swap partition on disk, which is larger than the RAM size.

As Ryan says, bug 1087324 is likely a duplicate of this bug, and the fix for it will land at latest in 3.5. For now the customer can try to workaround this issue by setting the SWAP size to a reasonable default during the installation.

Please let me know if that workaround works.

Comment 4 haiyang,dong 2014-08-06 02:19:37 UTC

*** This bug has been marked as a duplicate of bug 1099384 ***


Note You need to log in before you can comment on or make changes to this bug.