Bug 1118846 - RFE for LTSP support in RHEL 7 [NEEDINFO]
Summary: RFE for LTSP support in RHEL 7
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: distribution
Version: 7.2
Hardware: x86_64
OS: Linux
low
high
Target Milestone: rc
: ---
Assignee: RHEL Product and Program Management
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks: 1203710
TreeView+ depends on / blocked
 
Reported: 2014-07-11 16:51 UTC by Andrew Riell
Modified: 2019-03-05 23:30 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-05 21:36:30 UTC
snagar: needinfo? (nobody+bgollahe)


Attachments (Terms of Use)

Description Andrew Riell 2014-07-11 16:51:36 UTC
Description of problem:

RFE - Add LTSP to RHEL 7


Version-Release number of selected component (if applicable):

Latest.

How reproducible:

N/A

Steps to Reproduce:

N/A

Actual results:


Expected results:


Additional info:

Here are LANL's (SFDC acct: 129791) comments:

Candidate Solution: the Linux Terminal Server Project, LTSP. http://www.ltsp.org/

Definitions:
Terminal Services - A single system image, usually running directly on the hardware, that is scaled to support 10-50 different users simultaneously. This is a computing model that dates back to serial protocol green screen terminals like the VT100.

Virtual Desktop Infrastructure, VDI - Desktop images that are provided by virtualization technology. The solution requires a virtualization farm and a "cloud director" to connect clients to images. VMWare view is a leading technology in this space.

Business Case:

Los Alamos National Laboratory, and many other Federal customers (DOE, DOD, NSA, etc) have a critical need for a Zero Client, Terminal Services solution for Linux computing. In our secure environments we have orders to use only clients with zero local storage. This is a measure intended to help prevent the theft of sensitive data.This eliminates from consideration several existing solutions that rely on lightweight embedded versions of operating systems in "thin" clients.

Our go-to technology in this space for the past 5 years has been the Sun Ray. Earlier this year Oracle decided to terminate the Sun Ray product (hardware and software), leaving a significant capability gap unfilled.

Terminal services as a solution space has been somewhat neglected in favor of "sexier" solutions like virtualization based VDI. However for many workloads Terminal services is superior to VDI as the I/O and Memory sharing is more efficient within a single image than it is between system images in VDI. There is also a reduced per/user workload as system daemons (loggers, etc) are not replicated per-session in Terminal Services as they are in a VDI solution.

In addition to our need to have processing and storage happen in one place while display happens in another, terminal services also meets a number of other solution spaces: Low cost activity tracking stations or point of sale systems. Terminal services has a strong presence in Education world wide as it is a very cost efficient way to create a computing based classroom environment.

In fact, packaged and enhanced properly, the underpinnings of Terminal Services (booting thin clients over a network), could be used to support a number of different workloads that utilize stateless nodes; HPC, open stack compute systems, etc.

In short: This is a make or break capability for LANL that impacts approximately 1500 people at this institution alone. We need a solid solution in this space and we will change distributions over this functionality if needed. This also represents an opportunity for Red Hat to grow market share and develop a foundation package that can be used to enable several high value use cases.

Intended Workloads: Support software developers, computer scientists, physicists and engineers. Tasks ranging from text editing & e-mail all the way up to CAD and visualization.

Requirements:
Terminal Services style Zero Client solution.
Terminal Services (multiple users, one system image) not VDI (one system image per user virtualized).
Secure communications channel.
No OS Image required on Client Device (no embedded OS).
Use of standard client hardware (multiple vendors)
1 or more clients capable of being Tempest certified.
Maintenance of client root integrated into maintenance of boot server (e.g. yum update client-root, not chroot /foo/clients, script to setup environment, yum update, bar.sh which fixes a bunch of stuff after the update, exit chroot)
Packaged solution (vendor supported, easy install. Not custom crafted twitchy configuration)
Support for HSPD-12/CAC authentication.
Support for 32 and 64bit applications.

Desired Features:
"Follow me" sessions. (Login with smart card, pull card w/o logging out, go to 2nd station, put card in, login, get session in state that it was on station 1).
High performance graphics with support for 2 30 inch displays at 2560X1600@60Hz.
Client support for common multimedia technologies (sound and video work at client, Youtube etc. works at client.)
Client support for rich web technologies (Java, Flash, Javascript, HTML5 including video).
Support for session selection menu (e.g. power on thin client, Get screen that says do you want a session on this RHEL server, that RHEL server or this other Windows server)
Session shadow support tool (user calls in with problem, tech 'shadows' user session, sees what user sees and can interact with desktop. Requires user to acknowledge and allow connection).

Implications:
N.B. This is a workstation solution and it carries with it the implicit assumption that Red Hat will re-commit to providing a strong workstation environment including providing a broad package selection and keeping it updated.

Comment 2 Ondrej Vasik 2014-07-11 19:37:57 UTC
basesystem != distribution.

Comment 3 Siddharth Nagar 2015-04-15 14:34:59 UTC
After an initial triage, we've determined that this request is not a priority for RHEL 7.2. Deferring to RHEL 7.3.

Comment 8 Siddharth Nagar 2017-01-05 21:36:30 UTC
Inclusion of LTSP is not something we can support at this time.


Note You need to log in before you can comment on or make changes to this bug.