Bug 1118862 - Unable to add new nodes to old districts
Summary: Unable to add new nodes to old districts
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node
Version: 2.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Luke Meyer
QA Contact: libra bugs
URL:
Whiteboard:
Depends On: 1118417
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-11 18:20 UTC by Brenton Leanhardt
Modified: 2014-09-18 15:20 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1118417
Environment:
Last Closed: 2014-07-11 19:03:05 UTC


Attachments (Terms of Use)

Description Brenton Leanhardt 2014-07-11 18:20:12 UTC
+++ This bug was initially created as a clone of Bug #1118417 +++

Description of problem:
We have some old districts that used to contain at least 3 nodes each. They haven't been used in some time, since we retired some nodes. (But they still contain 1-2 nodes from back when they were created.)

Now, when we try to put some new nodes into the old districts, it gives us an error and fails to add the nodes to the districts.

[tmcgonag@ex-srv1.prod ~]$ sudo oo-admin-ctl-district -c add-node -n std95 -i ex-std-node102.prod.rhcloud.com

/usr/sbin/oo-admin-ctl-district:215:in `casecmp': can't convert nil into String (TypeError)
	from /usr/sbin/oo-admin-ctl-district:215:in `block in <main>'
	from /usr/sbin/oo-admin-ctl-district:178:in `block in collate_errors'
	from /usr/sbin/oo-admin-ctl-district:176:in `each'
	from /usr/sbin/oo-admin-ctl-district:176:in `collate_errors'
	from /usr/sbin/oo-admin-ctl-district:213:in `<main>'

However, when we create a *new* district for the new nodes, we can add them just fine. We're currently creating new districts and then adding 3 nodes to each one.

Version-Release number of selected component (if applicable):
openshift-origin-broker-util-1.25.3-1.el6oso.noarch

How reproducible:
Every time.

Steps to Reproduce:
1. Attempt to add nodes to one of the old districts (which contain 1-2 nodes).
2.
3.

Actual results:
Add-node fails.

Expected results:
Add-node should succeed to add the node to the old district.

Additional info:

Comment 1 Luke Meyer 2014-07-11 19:03:05 UTC
I don't think this is present in OSE 2.1. We didn't get the "platform" stuff in our districts or tool (which appears to be the issue).


Note You need to log in before you can comment on or make changes to this bug.