Bug 1118913 - [abrt] firewall-config: firewall-config:2060:onChangeZone:TypeError: 'NoneType' object is not iterable
Summary: [abrt] firewall-config: firewall-config:2060:onChangeZone:TypeError: 'NoneTyp...
Keywords:
Status: CLOSED DUPLICATE of bug 995760
Alias: None
Product: Fedora
Classification: Fedora
Component: firewalld
Version: 20
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:7c0092cacedb56bcb1c7b8fcb14...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-11 22:15 UTC by Hugo
Modified: 2014-07-14 10:00 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-14 10:00:56 UTC


Attachments (Terms of Use)
File: backtrace (750 bytes, text/plain)
2014-07-11 22:15 UTC, Hugo
no flags Details
File: environ (1.40 KB, text/plain)
2014-07-11 22:15 UTC, Hugo
no flags Details

Description Hugo 2014-07-11 22:15:28 UTC
Version-Release number of selected component:
firewall-config-0.3.10-1.fc20

Additional info:
reporter:       libreport-2.2.2
cmdline:        /usr/bin/python -Es /usr/bin/firewall-config
executable:     /usr/bin/firewall-config
kernel:         3.15.3-200.fc20.i686
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
firewall-config:2060:onChangeZone:TypeError: 'NoneType' object is not iterable

Traceback (most recent call last):
  File "/usr/bin/firewall-config", line 2060, in onChangeZone
    for item in rules:
TypeError: 'NoneType' object is not iterable

Local variables in innermost frame:
masquerade: False
name: 'time-exceeded'
_services: []
sources: []
default: False
_icmpblocks: []
interfaces: ['p2p1', 'wlp6s0']
args: (<TreeSelection object at 0x8debdec (GtkTreeSelection at 0x8b1de90)>,)
iter: None
self: <__main__.FirewallConfig object at 0x8ad14cc>
item: ['631', 'tcp']
builtin: False
icmpblocks: []
rules: None
services: ['dhcpv6-client', 'ipp-client', 'mdns', 'ssh']
active_zone: 'public'
ports: [['631', 'udp'], ['631', 'tcp']]
forward_ports: []

Comment 1 Hugo 2014-07-11 22:15:30 UTC
Created attachment 917449 [details]
File: backtrace

Comment 2 Hugo 2014-07-11 22:15:31 UTC
Created attachment 917450 [details]
File: environ

Comment 3 Jiri Popelka 2014-07-14 10:00:56 UTC

*** This bug has been marked as a duplicate of bug 995760 ***


Note You need to log in before you can comment on or make changes to this bug.