Bug 1118928 - $releasever and $arch substitution in kickstart 'url' field not working
Summary: $releasever and $arch substitution in kickstart 'url' field not working
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 20
Hardware: x86_64
OS: All
unspecified
medium
Target Milestone: ---
Assignee: Brian Lane
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-12 01:13 UTC by Adam Williamson
Modified: 2014-07-15 04:27 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-14 18:41:52 UTC


Attachments (Terms of Use)
anaconda.log from an affected f20 install (10.26 KB, text/plain)
2014-07-12 01:21 UTC, Adam Williamson
no flags Details
packaging.log from an affected run (1012 bytes, text/plain)
2014-07-12 01:26 UTC, Adam Williamson
no flags Details
program.log from an affected install (25.17 KB, text/plain)
2014-07-12 01:27 UTC, Adam Williamson
no flags Details
journal output from an affected install (96.92 KB, text/plain)
2014-07-12 01:28 UTC, Adam Williamson
no flags Details

Description Adam Williamson 2014-07-12 01:13:31 UTC
According to https://fedoraproject.org/wiki/Anaconda/Kickstart#url it should be possible to use $releasever and $arch in the 'url' kickstart parameter and have them substituted appropriately, but this does not appear to work. I've tested with 19, 20 and 21/rawhide, it does not work in any of them; I'm filing this against 20 because I believe the situation for 21/rawhide is complicated by the use of dnf.

There is a kickstart at http://fedorapeople.org/groups/qa/kickstarts/base-net-generic.ks which should be usable to reproduce this bug, it contains the following line:

url --mirrorlist=https://mirrors.fedoraproject.org/mirrorlist?repo=fedora-$releasever&arch=$arch

but when booting a netinst ISO from 19, 20 or 21 with 'inst.ks=ttp://fedorapeople.org/groups/qa/kickstarts/base-net-generic.ks' , the installer stops at the hub with the Installation Source hub in error state, showing the message "Error setting up base repository". If you enter the hub, it shows the URL exactly as written in the kickstart - that is, without $releasever and $arch being substituted.

bcl asked me to look for a line "adding yum repo, name: ..." in the logs, but no such line appears to be present. I will attach logs from a Fedora 20 reproduction of this bug, using the official release F20 x86_64 netinst.iso image.

Comment 1 Adam Williamson 2014-07-12 01:21:23 UTC
Created attachment 917461 [details]
anaconda.log from an affected f20 install

Comment 2 Adam Williamson 2014-07-12 01:26:03 UTC
Created attachment 917462 [details]
packaging.log from an affected run

Note interesting line:

23:24:19,996 ERR packaging: base repo (url/None) not valid -- removing it

Comment 3 Adam Williamson 2014-07-12 01:27:28 UTC
Created attachment 917463 [details]
program.log from an affected install

Comment 4 Adam Williamson 2014-07-12 01:28:21 UTC
Created attachment 917464 [details]
journal output from an affected install

Comment 5 Brian Lane 2014-07-14 18:41:52 UTC
$basearch not $arch, sorry I didn't notice before.

Comment 6 Adam Williamson 2014-07-15 04:16:46 UTC
well shoot, I dunno how I didn't notice that either! I'll check it works with the change applied. D'oh.

Comment 7 Adam Williamson 2014-07-15 04:27:21 UTC
yeah, seems to work. sorry for the pebkac.


Note You need to log in before you can comment on or make changes to this bug.