Bug 1118941 - [RFE][neutron]: Remove the use of resource autodeletion in unit tests
Summary: [RFE][neutron]: Remove the use of resource autodeletion in unit tests
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron
Version: unspecified
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ga
: 6.0 (Juno)
Assignee: lpeer
QA Contact: Ofer Blaut
URL: https://blueprints.launchpad.net/neut...
Whiteboard: upstream_milestone_juno-rc1 upstream_...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-12 04:05 UTC by RHOS Integration
Modified: 2016-04-26 22:07 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-01-12 22:03:23 UTC


Attachments (Terms of Use)

Description RHOS Integration 2014-07-12 04:05:32 UTC
Cloned from launchpad blueprint https://blueprints.launchpad.net/neutron/+spec/remove-unit-test-autodeletion.

Description:

The Neutron unit tests currently decorate resource creation methods with contextlib.contextmanager to allow resources to be automatically deleted when they are no longer needed.  This strategy is a legacy of a time when this explicit cleanup was required to ensure isolation between tests, but is now unnecessary since db state is automatically thrown away after each test.  Given that autodeletion has an execution and code maintenance penalty, its removal is adviseable.

Specification URL (additional information):

None

Comment 4 Lon Hohberger 2015-01-12 22:03:23 UTC
Removal of unit tests is not a bug.


Note You need to log in before you can comment on or make changes to this bug.