Bug 111896 - Can't maximize xemacs windows under metacity
Summary: Can't maximize xemacs windows under metacity
Status: CLOSED DUPLICATE of bug 111225
Alias: None
Product: Fedora
Classification: Fedora
Component: xemacs (Show other bugs)
(Show other bugs)
Version: 2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-12-11 13:37 UTC by Sylvain Ferrand
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:00:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sylvain Ferrand 2003-12-11 13:37:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031010

Description of problem:
I'm running xemacs under the gnome environment, with metacity as
window manager. When I try to maximize the window, xemacs freeze. When
I minimize the window it works again. The manual resizing of the
window works normally.

Version-Release number of selected component (if applicable):
metacity-2.6.3-1

How reproducible:
Always

Steps to Reproduce:
1.run xemacs under the gnome environment
2.'click' the maximize windows
    

Actual Results:  xemacs hang

Expected Results:  The windows should be normally maximized

Additional info:

Comment 1 rudi 2004-02-26 21:23:26 UTC
I can reproduce this bug every time. If maximising is a habit for you,
it's quite hard not to hit this bug over and over and over.
And over again.

I looked around a bit and found something related upstream:
http://list-archive.xemacs.org/xemacs-beta/200312/msg00218.html

Comment 2 Jens Petersen 2004-06-06 17:03:40 UTC
According to the upstream message it seems likely this a problem with
metacity not following the Xt protocol:

|I think this is the known bug where Metacity insists on maximizing to
|the pixel, but XEmacs wants character cell sizes.  For some reason,
|the negotiation gets into a loop.  Sometimes (if the hardware is not
|too fast) the loop is visible as flickering in the upper-right corner.
|
|I tend to suspect that Metacity is not putting its foot down and
|saying "this is your geometry---live with it", which is what the
|parent window is supposed to do.  I'm pretty sure that XEmacs does its
|geometry negotiation properly according to Xt standards; I know that
|GNOME basically does not care if non-GNOME applications work (that is,
|it's definitely a secondary priority and in practice it rarely gets
|much attention).  I think if you use the GNOME build it will work |fine.

*** This bug has been marked as a duplicate of 111225 ***

Comment 3 Red Hat Bugzilla 2006-02-21 19:00:22 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.