Bug 1118969 - Backlight cannot be adjusted for 2008 Macbook hardware 4,1
Summary: Backlight cannot be adjusted for 2008 Macbook hardware 4,1
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 20
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-12 14:06 UTC by Charles Stanhope
Modified: 2014-07-17 10:25 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-17 06:33:18 UTC


Attachments (Terms of Use)

Description Charles Stanhope 2014-07-12 14:06:05 UTC
With prior kernel revisions up to 3.14.8-200.fc20.x86_64 I have been able to adjust the brightness of my LCD backlight using the normal controls (e.g. gnome shell slider or keyboard). As of 3.15.3, I can no longer do so. I only discovered this once my screen had turned off after I had walked away from the computer for a while. When I returned, the backlight was not on, and I was unable to get it to turn on even though the computer was still running.

I have searched through many of the bug reports and I have tried, I think, all the combinations of video.use_native_backlight=1, acpi_backlight=vendor/video, acpi_osi=Linux, acpi_osi="!Windows 2012", etc. No combination of these kernel command line options causes my backlight driver to appear.

When running on 3.14.8 this is the information I get for the backlight driver:

$ ls -l /sys/class/backlight/
total 0
lrwxrwxrwx. 1 root root 0 Jul 11 21:05 intel_backlight -> ../../devices/pci0000:00/0000:00:02.0/drm/card0/card0-LVDS-1/intel_backlight

When running on 3.15.3 or 3.15.4 the /sys/clas/backlight directory is empty.
$ uname -a
Linux huginn 3.15.4-200.fc20.x86_64 #1 SMP Mon Jul 7 14:24:41 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
$ ls -l /sys/class/backlight/
total 0
$

$ sudo lspci -v -s 00:02
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) (rev 03) (prog-if 00 [VGA controller])
        Subsystem: Apple Inc. Device 00a1
        Flags: bus master, fast devsel, latency 0, IRQ 44
        Memory at d0100000 (64-bit, non-prefetchable) [size=1M]
        Memory at c0000000 (64-bit, prefetchable) [size=256M]
        I/O ports at 6110 [size=8]
        Expansion ROM at <unassigned> [disabled]
        Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
        Capabilities: [d0] Power Management version 3
        Kernel driver in use: i915
        Kernel modules: i915

00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (secondary) (rev 03)
        Subsystem: Apple Inc. Device 00a1
        Flags: fast devsel
        Memory at d0200000 (64-bit, non-prefetchable) [disabled] [size=1M]
        Capabilities: [d0] Power Management version 3

The problem persists with the external display unplugged.

$ cat /proc/cmdline
BOOT_IMAGE=/vmlinuz-3.14.8-200.fc20.x86_64 root=/dev/mapper/fedora-root ro rd.lvm.lv=fedora/swap vconsole.font=latarcyrheb-sun16 rd.lvm.lv=fedora/root rhgb quiet LANG=en_US.UTF-8

(Command line is the same for 3.15.4 except the kernel.)

$ grep '.*' /sys/class/dmi/id/*_* 2> /dev/null
/sys/class/dmi/id/bios_date:02/09/08
/sys/class/dmi/id/bios_vendor:Apple Inc.
/sys/class/dmi/id/bios_version:    MB41.88Z.00C1.B00.0802091535
/sys/class/dmi/id/board_asset_tag:Base Board Asset Tag
/sys/class/dmi/id/board_name:Mac-F22788A9
/sys/class/dmi/id/board_vendor:Apple Inc.
/sys/class/dmi/id/board_version:PVT
/sys/class/dmi/id/chassis_asset_tag:Asset Tag#
/sys/class/dmi/id/chassis_type:2
/sys/class/dmi/id/chassis_vendor:Apple Inc.
/sys/class/dmi/id/chassis_version:Mac-F22788A9
/sys/class/dmi/id/product_name:MacBook4,1
/sys/class/dmi/id/product_version:1.0
/sys/class/dmi/id/sys_vendor:Apple Inc.

Version-Release number of selected component (if applicable):
Kernels 3.15.3 and 3.15.4 exhibit this problem.

How reproducible:
Always

Steps to Reproduce:
1. Boot
2. See that the backlight driver hasn't been enumerated
3. There will be no controls available in the gnome session etc.

Actual results:
Nothing

Expected results:
Ability to adjust brightness of the builtin LCD screen

Additional info:
$ rpm -q gnome-shell
gnome-shell-3.10.4-5.fc20.x86_64

Comment 1 jens stein 2014-07-12 16:18:37 UTC
I have this problem too on a macbook 2,1 (2007).
On kernels prior to 3.15, /sys/class/backlight had both apple_backlight and intel_backlight. Now I only have apple_backlight.
Various kernel command line parameters like ascpi_osi, video.use_native_backlight, etc don't make any difference for my either. Adding this to /etc/X11/xorg.conf.d/20-intel.conf doesn't help either:
Section "Device"
        Identifier  "card0"
        Driver      "intel"
        Option      "Backlight"  "intel_backlight"
        BusID       "PCI:0:2:0"
EndSection

uname -a:
Linux fedora 3.15.4-200.fc20.i686+PAE #1 SMP Mon Jul 7 14:45:01 UTC 2014 i686 i686 i386 GNU/Linux

lspci:
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03) (prog-if 00 [VGA controller])
	Subsystem: Intel Corporation Device 7270
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0
	Interrupt: pin A routed to IRQ 16
	Region 0: Memory at d0380000 (32-bit, non-prefetchable) [size=512K]
	Region 1: I/O ports at 20e0 [size=8]
	Region 2: Memory at c0000000 (32-bit, prefetchable) [size=256M]
	Region 3: Memory at d0400000 (32-bit, non-prefetchable) [size=256K]
	Expansion ROM at <unassigned> [disabled]
	Capabilities: [90] MSI: Enable- Count=1/1 Maskable- 64bit-
		Address: 00000000  Data: 0000
	Capabilities: [d0] Power Management version 2
		Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
		Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
	Kernel driver in use: i915
	Kernel modules: i915

00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
	Subsystem: Intel Corporation Device 7270
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0
	Region 0: Memory at d0300000 (32-bit, non-prefetchable) [size=512K]
	Capabilities: [d0] Power Management version 2
		Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
		Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-


Additionally /sys/class/backlight/apple_backlight/brightness doesn't respond to changes after a suspend. Any value between 1 and 15 (maximum) results in something like full brightness. This may well be another bug though, and could be related to https://bugzilla.redhat.com/show_bug.cgi?id=989555.

Comment 2 Hans de Goede 2014-07-12 18:24:47 UTC
Hi,

This sounds like it is caused by recent changes to the backlight handling in the intel driver, can you please file a bug with the intel folks:

https://01.org/linuxgraphics/documentation/how-report-bugs

Thanks,

Hans

Comment 3 Charles Stanhope 2014-07-16 03:19:53 UTC
Sorry it took me a while to get back to this. Before submitting a bug there, I did some digging. I uncovered a chromebook bug that seemed very similar to this one:

https://bugs.freedesktop.org/show_bug.cgi?id=79813

That bug links to another bug on the kernel bug tracker specifically discussing backlight issue on Macbook 4,1:

https://bugzilla.kernel.org/show_bug.cgi?id=77831

It appears to be reported and fixed (fortunately I'm not the only oddball trying to make his quirky Mac hardware last a little while longer). So presumably the fix will show up in Fedora's kernels at some point?

Thanks for the help.

Comment 4 Hans de Goede 2014-07-16 06:51:33 UTC
(In reply to Charles Stanhope from comment #3)
> https://bugzilla.kernel.org/show_bug.cgi?id=77831

Ah yes, that one, that is fixed in 3.15.5 so this kernel build should fix things:
http://koji.fedoraproject.org/koji/buildinfo?buildID=543830

Can you download the kernel-3.15.5-...rpm for you architecture, install it with "rpm -ivh kernel-3.15.5-...rpm", and see if it fixes things?

Comment 5 jens stein 2014-07-16 07:44:32 UTC
(In reply to Hans de Goede from comment #4)

unfortunately, 3.15.5 does not fix the issue for me and my macbook 2,1. i guess the hardware is too different then.
should i report this separately to the kernel bugzilla, to the intel bug tracker or here at red hat's bug tracker? i can't seem to find anyone else with a 2,1 with this issue.

Comment 6 Hans de Goede 2014-07-16 08:15:31 UTC
Hi,

(In reply to jens stein from comment #5)
> (In reply to Hans de Goede from comment #4)
> 
> unfortunately, 3.15.5 does not fix the issue for me and my macbook 2,1. i
> guess the hardware is too different then.
> should i report this separately to the kernel bugzilla, to the intel bug
> tracker or here at red hat's bug tracker? i can't seem to find anyone else
> with a 2,1 with this issue.

It is probably best to report this directly to the intel gfx developers, using the procedure described here: https://01.org/linuxgraphics/documentation/how-report-bugs

Regards,

Hans

Comment 7 Charles Stanhope 2014-07-17 03:06:55 UTC
(In reply to Hans de Goede from comment #4)
> Ah yes, that one, that is fixed in 3.15.5 so this kernel build should fix
> things:
> http://koji.fedoraproject.org/koji/buildinfo?buildID=543830
> 
> Can you download the kernel-3.15.5-...rpm for you architecture, install it
> with "rpm -ivh kernel-3.15.5-...rpm", and see if it fixes things?

Looks good! Backlight control is back! Thank you again for the help.

Comment 8 Hans de Goede 2014-07-17 06:33:18 UTC
Hi,

(In reply to Charles Stanhope from comment #7)
> (In reply to Hans de Goede from comment #4)
> > Ah yes, that one, that is fixed in 3.15.5 so this kernel build should fix
> > things:
> > http://koji.fedoraproject.org/koji/buildinfo?buildID=543830
> > 
> > Can you download the kernel-3.15.5-...rpm for you architecture, install it
> > with "rpm -ivh kernel-3.15.5-...rpm", and see if it fixes things?
> 
> Looks good! Backlight control is back! Thank you again for the help.

Ok, closing this one then (3.15.5 should show up as an official Fedora update soonish).

As for the 2,1 macbook please file a bug with the Intel folks for that. If a patch comes out of that and you would like to see that get added to the Fedora kernels, please file a new bug for that and put me in the CC.

Comment 9 jens stein 2014-07-17 10:25:22 UTC
For anyone interested, I filed a bug with Intel for the 2,1 macbook here: https://bugs.freedesktop.org/show_bug.cgi?id=81438


Note You need to log in before you can comment on or make changes to this bug.