Bug 111897 - builtins manpage error
builtins manpage error
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: bash (Show other bugs)
2.1
noarch Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-11 08:56 EST by Michael Humphries-Dolnick
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-11 11:43:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Humphries-Dolnick 2003-12-11 08:56:40 EST
Description of problem:


Version-Release number of selected component (if applicable):bash-
2.05-8, kernel 2.4.9-e.25enterprise


How reproducible: consistently in our environment


Steps to Reproduce:
1. type 'man 1 umask'
  
Actual results:
<standard input>:14: realpath on `bash.1' failed: No such file or 
directory

Expected results: bash builtins manpage


Additional info: One developer at our site adds this:
The error is emitted by "/usr/bin/nroff -mandoc" but it is only 
persuaded to by the input. The problem seems to be with the line:

	.so bash.1

(inside /usr/share/man/man1/builtins.1.gz itself).

Some problem with actual paths vs. configured paths, or else broken 
behaviour of the nroff ".so" directive maybe?
Comment 1 Tim Waugh 2003-12-11 11:43:29 EST
This has been fixed in 2.05b-19 onwards.

Note You need to log in before you can comment on or make changes to this bug.