Bug 1118982 - xfce4-terminal has hijacked the backspace key
Summary: xfce4-terminal has hijacked the backspace key
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xfce4-terminal
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-12 17:01 UTC by Martin Gregorie
Modified: 2014-07-12 20:47 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-12 20:47:57 UTC


Attachments (Terms of Use)

Description Martin Gregorie 2014-07-12 17:01:19 UTC
Description of problem: 

xfce4-terminal now grabs the backspace key for its exclusive use. It uses it as a short cut to toggle 'show window borders' on and off: toggling the borders on and off is not something I use and in any case, even if I did use it, would be of much less importance than passing a BS character to the program I'm running. This behaviour was not apparent last week but seems to have appeared following a 'yum upgrade' that I did last night, 11 July 2014. 

I use a terminal-mode text editor and other programs that need to distinguish between the backspace and delete keys, but now there is no way that I can make the backspace key available to these programs other than tediously entering Ctrl-h.

xfce4-terminal's 'View' menu indicates that "Show window borders" uses the backspace key as a short cut but neither the Edit:Preferences:Compatibility nor the Edit:Preferences:Advanced panes provide any means of disabling this shortcut. 

Please provide a means of disabling this shortcut or remove it entirely.

Version-Release number of selected component (if applicable): 
xfce4-terminal 0.6.3

How reproducible: 
Seems to be a new 'feature' that appeared with the upgrade I did after 16:00 on 11 July 2014.

Steps to Reproduce:
1. Open a terminal emulator window
1. Start any program that accepts keystrokes and displays their effect in 
   the window.
2. Hit the 'backspace' key a few times.
3. Watch the terminal window's borders flash off and on while ovserving 
   that the program, which should be receiving the keystrokes, is not
   receiving them
4. Hit any other key the program should accept and observe that the borders
   do not change while the program is receiving the keystrokes.


Actual results:
Whenever the 'backspace' key is pressed to Terminal window's borders toggle on or off and the program, which should receive the BS character, doesn't receive anything.

Expected results:
The Terminal window's borders should remain unchanged. The program should receive the BS character.

Additional info:
Using xfce4-terminal's Edit:Preferences:Compatibility menu item to change the character code assigned to the key does not affect this mis-feature.

Comment 1 Kevin Fenzi 2014-07-12 17:27:39 UTC
This sounds like you have 'editable menu accelerators' enabled and have inadvertently set that menu item to backspace. 

Open your terminal window. 
Click on view menu option
hover the mouse over the 'show window borders' option. 
hit backspace

The item should no longer run when you hit backspace.

Comment 2 Martin Gregorie 2014-07-12 20:15:04 UTC
That fixed it, thanks.

Comment 3 Kevin Fenzi 2014-07-12 20:47:57 UTC
Excellent.


Note You need to log in before you can comment on or make changes to this bug.