Bug 1119012 - test --help not showing in terminal
Summary: test --help not showing in terminal
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: coreutils
Version: 6.5
Hardware: Unspecified
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: Ondrej Vasik
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-13 04:11 UTC by cybernet
Modified: 2014-07-14 12:28 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-13 15:42:08 UTC


Attachments (Terms of Use)

Description cybernet 2014-07-13 04:11:44 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. open terminal
2. su root
3. test --help

Actual results:
NULL

Expected results:
Help Menu :)

Additional info:

Comment 3 Ondrej Vasik 2014-07-13 15:42:08 UTC
Stating documentation of coreutils:
"If EXPRESSION is omitted, `test' returns false.  If EXPRESSION is a
single argument, `test' returns false if the argument is null and true
otherwise.  The argument can be any string, including strings like
`-d', `-1', `--', `--help', and `--version' that most other programs
would treat as options.  To get help and version information, invoke
the commands `[ --help' and `[ --version', without the usual closing
brackets."

It is defined by posix that test should not accept --help and --version arguments ( http://pubs.opengroup.org/onlinepubs/009696799/utilities/test.html ) . [ --help and [ --version works as expected.

Even though I don't agree with the reassignment to coreutils - as the simple test is shell builtin , closing not a bug, as this behaviour is specified by posix.


Note You need to log in before you can comment on or make changes to this bug.