Bug 1119016 - Packstack: after a packstack based installation, some RPMs are not the latest
Summary: Packstack: after a packstack based installation, some RPMs are not the latest
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: RDO
Classification: Community
Component: openstack-packstack
Version: unspecified
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: ---
Assignee: Martin Magr
QA Contact: Ami Jeain
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-13 06:33 UTC by Yaniv Kaul
Modified: 2015-03-27 01:55 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-27 01:55:06 UTC


Attachments (Terms of Use)

Description Yaniv Kaul 2014-07-13 06:33:55 UTC
Description of problem:
Right after installation with Packstack, I perform 'yum update'. Note that first two RPMs:
==============================================================================================================================================================================================
 Package                                        Arch                                  Version                                         Repository                                         Size
==============================================================================================================================================================================================
Updating:
 pyOpenSSL                                      x86_64                                0.13.1-1.el6                                    openstack-icehouse                                129 k
 python-paramiko                                noarch                                1.10.1-2.el6                                    openstack-icehouse                                739 k
 ruby-augeas                                    x86_64                                0.4.1-3.el6                                     puppetlabs-deps                                    21 k
 ruby-shadow                                    x86_64                                1:2.2.0-2.el6                                   puppetlabs-deps                                    13 k

Transaction Summary
==============================================================================================================================================================================================
Upgrade       4 Package(s)


Why aren't they installed as part of the packstack installation?

Version-Release number of selected component (if applicable):
openstack-packstack-2014.1.1-0.21.dev1157.1.el6.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Lars Kellogg-Stedman 2015-03-27 01:55:06 UTC
Packstack does not perform a yum update/upgrade on the system.  If some packages are already installed prior to running packstack and they are able to satisfy package or puppet dependencies they would not necessarily get upgraded.

Unless you are experiencing problems caused by outdated packages, this is not necessarily a problem. In the event that something is failing due to a requirement being out-of-date, the solution is usually to file a bugzilla against that specific package so that it can be given a proper versioned requirement on the dependency.


Note You need to log in before you can comment on or make changes to this bug.