Bug 1119046 - "Auto broadband" menu item result in a js backtrace
Summary: "Auto broadband" menu item result in a js backtrace
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-shell
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Florian Müllner
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-13 15:07 UTC by M. Scherer
Modified: 2019-09-11 19:03 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-11 19:03:33 UTC


Attachments (Terms of Use)

Description M. Scherer 2014-07-13 15:07:23 UTC
Description of problem:
After plugging my mobile phone with usb on RHEL7, i did see that a new menu item appear in the network menu icon in gnome-shell, named "Auto broadnband". As I wanted to configure my phone to used it as modem, i clicked on it. Nothing happened.



Version-Release number of selected component (if applicable):
$ rpm -q gnome-shell
gnome-shell-3.8.4-32.el7_0.x86_64


How reproducible:
Each time

Steps to Reproduce:
1. Plug a phone ( a galaxy S II in my case )
2. Click on 'auto broadbnad' in the network menu
3.

Actual results:
Nothing

Expected results:
Likely a network manager popup should appear.

Additional info:

Here is what is written in the log 

JS ERROR: !!!   Exception in callback for signal: activate
JS ERROR: !!!     message = '"Invoking pure virtual function NMDevice.createAutomaticConnection"'
JS ERROR: !!!     fileName = '"/usr/share/gnome-shell/js/ui/status/network.js"'
JS ERROR: !!!     lineNumber = '518'
JS ERROR: !!!     stack = '"()@/usr/share/gnome-shell/js/ui/status/network.js:518
wrapper()@/usr/share/gjs-1.0/lang.js:213
([object Object],[object GObject_Union])@/usr/share/gnome-shell/js/ui/status/network.js:573
_emit("activate",[object GObject_Union])@/usr/share/gjs-1.0/signals.js:124
([object GObject_Union])@/usr/share/gnome-shell/js/ui/popupMenu.js:114
wrapper([object GObject_Union])@/usr/share/gjs-1.0/lang.js:213
([object GObject_Object],[object GObject_Union])@/usr/share/gnome-shell/js/ui/popupMenu.js:87
wrapper([object GObject_Object],[object GObject_Union])@/usr/share/gjs-1.0/lang.js:213
"'

Comment 3 M. Scherer 2015-09-04 22:02:47 UTC
So, due to interface change in RHEL 7.2, I cannot reproduce it. Not sure if it should be closed or not.


Note You need to log in before you can comment on or make changes to this bug.