Bug 1119068 - Fix unnecessary /proc dependency if getauxval(3) is available
Summary: Fix unnecessary /proc dependency if getauxval(3) is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rpm
Version: 7.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Florian Festi
QA Contact: Karel Srot
URL:
Whiteboard:
: 1190233 (view as bug list)
Depends On: 1145970
Blocks: 1205796 1154125
TreeView+ depends on / blocked
 
Reported: 2014-07-13 17:17 UTC by Harold Miller
Modified: 2019-08-15 03:54 UTC (History)
8 users (show)

Fixed In Version: rpm-4.11.3-1.el7
Doc Type: Bug Fix
Doc Text:
The RPM parser that generates the list of required packages previously generated incorrect dependencies when it found a "use" string in the perl.req script of the parsed package. As a consequence, installing or updating packages could in some case fail. This update fixes the underlying code, and packages now install or update successfully if their required packages are installed on the system.
Clone Of:
Environment:
Last Closed: 2015-11-19 11:58:13 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2138 normal SHIPPED_LIVE rpm bug fix and enhancement update 2015-11-19 10:39:52 UTC
Red Hat Knowledge Base (Solution) 1128683 None None None Never

Description Harold Miller 2014-07-13 17:17:42 UTC
From the customer:

 Description	

rpm errors about the /proc filesystem

bash-4.2# rpm -qa |grep which
warning: Failed to read auxiliary vector, /proc not mounted?
warning: Failed to read auxiliary vector, /proc not mounted?
warning: Failed to read auxiliary vector, /proc not mounted?
warning: Failed to read auxiliary vector, /proc not mounted?
warning: Failed to read auxiliary vector, /proc not mounted?
warning: Failed to read auxiliary vector, /proc not mounted?
warning: Failed to read auxiliary vector, /proc not mounted?
warning: Failed to read auxiliary vector, /proc not mounted?
bash-4.2# rpm -qa |grep vi
warning: Failed to read auxiliary vector, /proc not mounted?
warning: Failed to read auxiliary vector, /proc not mounted?
warning: Failed to read auxiliary vector, /proc not mounted?

This appears to be one of the items fixed in rpm 4.11.2 per release notes http://www.rpm.org/wiki/Releases/4.11.2

Fix unnecessary /proc dependency if getauxval(3) is available

Can we get this fixed in 4.11.1 as an errata?

---------------

Looks like the new rpm version expects some /proc population (in this case /proc/self/auxv). There is minimal /proc in the target aos image when building
bash-4.2# ls /proc/
modules mounts

Found this snippet of rpm source from google:
++#if defined(_linux_)
++/**
++ * Populate rpmat structure with parsed info from /proc/self/auxv
++ */
++static void parse_auxv(void)
++{
++ static int oneshot = 1;
++
++ if (oneshot) {
++	rpmat.platform = "";
++	int fd = open("/proc/self/auxv", O_RDONLY);
++
++	if (fd == -1)
{ ++	 rpmlog(RPMLOG_WARNING, ++	 _("Failed to read auxiliary vector, /proc not mounted?\n")); ++ return; ++	}
else {
++	 ElfW(auxv_t) auxv;
++	 while (read(fd, &auxv, sizeof(auxv)) == sizeof(auxv)) {
++ switch (auxv.a_type)
++
{ ++ case AT_NULL: ++ break; ++ case AT_PLATFORM: ++ rpmat.platform = strdup((char *) auxv.a_un.a_val); ++ break; ++ case AT_HWCAP: ++ rpmat.hwcap = auxv.a_un.a_val; ++ break; ++ }
++	 }
++	 close(fd);
++	}
++	oneshot = 0; /* only try once even if it fails */
++ }
++ return;
++}
++#endif

Comment 2 Panu Matilainen 2014-09-25 16:01:54 UTC
Lets try to fix this via rpm rebase in 7.2.

Comment 3 Florian Festi 2015-03-16 16:05:17 UTC
*** Bug 1190233 has been marked as a duplicate of this bug. ***

Comment 7 Florian Festi 2015-06-26 14:00:50 UTC
Should be included in the rebase.

Comment 10 Harold Miller 2015-08-20 15:55:41 UTC
Karel,
The customer is using 'bind mounting the file system' as a work-around. Is rpm-4.11.3-13.el7 now available via YUM? What is your recommended method of installing this update? I'd be happy to pass that along to the customer for testing, we just need to provide clear instructions for them to do so.

Comment 11 Karel Srot 2015-08-21 06:09:21 UTC
Hi Harold,
I didn't realize this is a customer reported bug. I will try to reproduce it on my own. Btw, AFAIK new rpm should be accessible once 7.2 Beta is public through respective channels.

Comment 13 errata-xmlrpc 2015-11-19 11:58:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2138.html


Note You need to log in before you can comment on or make changes to this bug.