Bug 1119072 - unreliable koops frames without function name are rejected by ABRT server
Summary: unreliable koops frames without function name are rejected by ABRT server
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: abrt
Version: 20
Hardware: ppc64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Michal Toman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1119301 1142338
TreeView+ depends on / blocked
 
Reported: 2014-07-13 18:44 UTC by Al Dunsmuir
Modified: 2015-03-23 00:42 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1119301 (view as bug list)
Environment:
Last Closed: 2014-07-29 08:17:12 UTC


Attachments (Terms of Use)
gdb generated backtrace (2.51 KB, text/plain)
2014-07-14 11:00 UTC, Al Dunsmuir
no flags Details
caja backtrace from gdb (4.41 KB, text/plain)
2014-07-14 11:11 UTC, Al Dunsmuir
no flags Details

Description Al Dunsmuir 2014-07-13 18:44:54 UTC
Description of problem:
When abrt is triggered on F20 on ppc64, it consistently does not recognize the backtrace.

I am experiencing errors in mate-control-center and kernel (Oops due to ATI X11 driver). 

Version-Release number of selected component (if applicable):
abrt.2.2.1-2.fc20.ppc64

How reproducible:
100% whenever I have exception so far.  kernel Oops happens every boot, and mate-control-center happens when I change display resolution (to fix up after kernel video error 8^( ) 


Steps to Reproduce:
1.
2.
3.

Actual results:
Backtrace processing failed

Expected results:
Backtrace showing failing component, and point of failure


Additional info:

Comment 1 Al Dunsmuir 2014-07-13 18:46:38 UTC
--- Running report_uReport ---
Generating core_backtrace
Generating backtrace
Error: Line 12, column 0: Frame header variant not recognized.
('report_uReport' exited with 1)

--- Running report_EmergencyAnalysis ---
Compressing data
Sending /var/tmp/ccpp-2014-07-09-20:19:09-2610.tar.gz to https://retrace.fedoraproject.org/faf/dumpdirs/new/
Successfully sent /var/tmp/ccpp-2014-07-09-20:19:09-2610.tar.gz to https://retrace.fedoraproject.org/faf/dumpdirs/new/

Comment 2 Jakub Filak 2014-07-14 09:04:21 UTC
Hello, thank you for the report. Could you please provide the ignored oops text?

Comment 3 Jakub Filak 2014-07-14 09:49:07 UTC
Could you also please provide a backtrace generated by your gdb?

$ cd /var/tmp/ccpp-2014-07-09-20:19:09-2610
$ gdb $(cat executable) -c coredump -batch -ex "t a a bt"

Comment 4 Al Dunsmuir 2014-07-14 10:37:34 UTC
BUG: soft lockup - CPU #1 stuck for 23s! [gmain:2435] - abrt
--- Running report_uReport ---
Server responded with an error: 'Validation failed: Element 'frames' is invalid: List element is invalid: Element 'function_name' is missing'
reporter-ureport failed with exit code 1
('report_uReport' exited with 1)

--- Running report_EmergencyAnalysis ---
Compressing data
Sending /var/tmp/oops-2014-07-13-11:43:56-1530-0.tar.gz to https://retrace.fedoraproject.org/faf/dumpdirs/new/
Successfully sent /var/tmp/oops-2014-07-13-11:43:56-1530-0.tar.gz to https://retrace.fedoraproject.org/faf/dumpdirs/new/

Comment 5 Al Dunsmuir 2014-07-14 10:59:28 UTC
For the gdb backtrace, files are under abrt directory.

$ cd /var/tmp/abrt/ccpp-2014-07-09-20:19:09-2610
$ gdb $(cat executable) -c coredump -batch -ex "t a a bt"

Output uploaded as 2610.txt

I don't see a /var/tmp/abrt/oops-2014-07-13-11:43:56-1530 directory.
- As the kernel oops trees are root/root, is it possible it is deleted for
  security reasons?

There is another abrt tree for a different kernel oops, but that does not have a coredump file.

Comment 6 Al Dunsmuir 2014-07-14 11:00:25 UTC
Created attachment 917749 [details]
gdb generated backtrace

Comment 7 Al Dunsmuir 2014-07-14 11:09:13 UTC
I have a new instance this morning.  it is consistent with the mate-control-center error, so I am including it in case this helps:

caja killed by sigtrap
--- Running report_uReport ---
Generating core_backtrace
Generating backtrace
Error: Line 10, column 4: Frame header variant not recognized.
('report_uReport' exited with 1)

--- Running report_EmergencyAnalysis ---
Compressing data
Sending /var/tmp/ccpp-2014-07-14-06:31:50-2271.tar.gz to https://retrace.fedoraproject.org/faf/dumpdirs/new/
Successfully sent /var/tmp/ccpp-2014-07-14-06:31:50-2271.tar.gz to https://retrace.fedoraproject.org/faf/dumpdirs/new/

Uploaded gdb traceback as 2271.txt

Comment 8 Al Dunsmuir 2014-07-14 11:11:05 UTC
Created attachment 917753 [details]
caja backtrace from gdb

Comment 9 Jakub Filak 2014-07-14 12:09:16 UTC
(In reply to Al Dunsmuir from comment #5)
> I don't see a /var/tmp/abrt/oops-2014-07-13-11:43:56-1530 directory.
> - As the kernel oops trees are root/root, is it possible it is deleted for
>   security reasons?
> 
No, I don't think so. It is more likely that ABRT deleted that directory because of lack of free space.

Thank you very much for the backtraces!

Comment 10 Jakub Filak 2014-07-23 06:23:48 UTC
The problem with the rejected koops is that the top most frame has no function name assigned. But the frame is flagged with "(unreliable)", so ABRT can reduce its requirements and accept the unreliable frames without function name.

Michal, would it be possible to adopt my suggestion? Or should we use some dummy function name on the client side?

Comment 11 Michal Toman 2014-07-24 08:42:44 UTC
I will modify the server so that such reports are accepted

Comment 12 Michal Toman 2014-07-29 08:17:12 UTC
Fixed in upstream and deployed.

commit e8ddcd6c2db5b60556848c57fbf51943fe74028b
Author: Michal Toman <mtoman@redhat.com>
Date:   Mon Jul 28 11:28:34 2014 +0200

    koops: add '_unknown_' if function name is missing in unreliable frame
    
    Signed-off-by: Michal Toman <mtoman@redhat.com>


Note You need to log in before you can comment on or make changes to this bug.