Bug 1119073 - Can not set network-manager-openvpn plugin routing settings from gnome-control
Summary: Can not set network-manager-openvpn plugin routing settings from gnome-control
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: NetworkManager-openvpn
Version: epel7
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Gwyn Ciesla
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-13 19:25 UTC by Raul Laansoo
Modified: 2016-12-31 10:47 UTC (History)
4 users (show)

Fixed In Version: NetworkManager-openvpn-1.2.6-1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-31 10:47:39 UTC


Attachments (Terms of Use)

Description Raul Laansoo 2014-07-13 19:25:37 UTC
Description of problem:

Can not set network-manager-openvpn routing settings from gnome-control.

NetworkManager-openvpn-0.9.8.2-4.el7.1.x86_64

How reproducible:

Always.

Steps to Reproduce:
1. Click on network connection on Gnome panel
2. Select Network Settings. 
3. Select VPN connection (VPN Type openvpn)
4. Click on Settings.
5. Select on IPv4
6. Activate 'Use this connection only for resources on its network'

Actual results:

Not possible to save this setting change (Apply not active)

Expected results:

Apply active, can save settings change.

Additional info:

Comment 2 Dan Williams 2014-07-16 17:21:17 UTC
Moving to Fedora EPEL since NetworkManager-openvpn is not available in RHEL7.

But anyway, what are your other VPN settings, especially those in the main OpenVPN options page?  If those settings are not correct or not complete, then "Apply" will not be enabled.  Also note that for any method that requires a CA certificate, you need to provide that certificate (since otherwise, the security aspects of the VPN are pointless...)

Comment 3 Raul Laansoo 2014-07-16 20:23:48 UTC
You are right. If I open the VPN settings window, private key password field is empty and that's why I can not save settings. Shouldn't password be saved to the keyring?

Comment 4 Raul Laansoo 2014-07-18 14:11:11 UTC
Clear NEEDINFO.

Comment 5 Fedora Update System 2016-12-14 18:32:40 UTC
NetworkManager-openvpn-1.2.6-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-1427c2b2fc

Comment 6 Fedora Update System 2016-12-16 04:19:44 UTC
NetworkManager-openvpn-1.2.6-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-1427c2b2fc

Comment 7 Fedora Update System 2016-12-31 10:47:39 UTC
NetworkManager-openvpn-1.2.6-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.