Bug 111915 - can't record from via82cxxx integrated audio device
Summary: can't record from via82cxxx integrated audio device
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 9
Hardware: athlon Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-12-11 15:55 UTC by darkeye
Modified: 2007-04-18 17:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 15:41:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description darkeye 2003-12-11 15:55:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031016

Description of problem:
when trying to record audio from the via82cxxx sound card integrated
in the motherboard, I can only record silence, no matter what mixer
settings I use.

Version-Release number of selected component (if applicable):
kernel-2.4.20-24.9

How reproducible:
Always

Steps to Reproduce:
1. provide some audio input, e.g. play a CD in the CD player
2. set the mixer so that CD is the recording device
3. record from /dev/dsp, by using sox or some other sound recording
software
    

Actual Results:  the recorded audio is plain silence.

Expected Results:  the recorded audio should contain the audio coming
in the channel set for recording by the mixer.

Additional info:

funny that the audio card works otherwise OK (e.g. I can play sound on
it, I can use the mixer to set volumes on different channels)

I tried getting input on different channels: line-in, mic, CD. I tried
to set the mixer to record on all possible channels. I tried to use
different mixers (aumix, gnome-mixer) and different recording programs
(sox, gnome-audio-recorder). all come to the same result: the recorded
audio was total silence.

Comment 1 Bugzilla owner 2004-09-30 15:41:44 UTC
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/



Note You need to log in before you can comment on or make changes to this bug.