Bug 1119167 - Disconnect log doesn't have space in between words
Summary: Disconnect log doesn't have space in between words
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: protocol
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pranith Kumar K
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-14 08:06 UTC by Pranith Kumar K
Modified: 2014-11-11 08:37 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.6.0beta1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-11 08:37:01 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Pranith Kumar K 2014-07-14 08:06:21 UTC
Description of problem:
[2014-07-14 08:05:20.277299] I [server.c:518:server_rpc_notify] 0-r2-server: disconnecting connectionfrom pranithk-laptop-28581-2014/07/14-08:05:16:318216-r2-client-0-0-0

There should be a space between connection & from

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Mount glusterfs volume
2. Unmount will result in the log above
3.

Actual results:


Expected results:


Additional info:

Comment 1 Anand Avati 2014-07-14 08:08:09 UTC
REVIEW: http://review.gluster.org/8304 (protocol/server: Add extra space between words) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 2 Anand Avati 2014-07-14 13:27:50 UTC
COMMIT: http://review.gluster.org/8304 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit f637f2f101b13388187f8a6852d3ae6f1d9c2ad5
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Mon Jul 14 12:49:58 2014 +0530

    protocol/server: Add extra space between words
    
    Change-Id: Id658db992a43202602e0c30d2c8ca639c4aeadd6
    BUG: 1119167
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/8304
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Humble Devassy Chirammal <humble.devassy@gmail.com>

Comment 3 Niels de Vos 2014-09-22 12:44:48 UTC
A beta release for GlusterFS 3.6.0 has been released. Please verify if the release solves this bug report for you. In case the glusterfs-3.6.0beta1 release does not have a resolution for this issue, leave a comment in this bug and move the status to ASSIGNED. If this release fixes the problem for you, leave a note and change the status to VERIFIED.

Packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update (possibly an "updates-testing" repository) infrastructure for your distribution.

[1] http://supercolony.gluster.org/pipermail/gluster-users/2014-September/018836.html
[2] http://supercolony.gluster.org/pipermail/gluster-users/

Comment 4 Niels de Vos 2014-11-11 08:37:01 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.6.1, please reopen this bug report.

glusterfs-3.6.1 has been announced [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://supercolony.gluster.org/pipermail/gluster-users/2014-November/019410.html
[2] http://supercolony.gluster.org/mailman/listinfo/gluster-users


Note You need to log in before you can comment on or make changes to this bug.