This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 111919 - Using up2date to install GnuPG Assistant (gpa) fails with "TypeError: unsubscriptable object"
Using up2date to install GnuPG Assistant (gpa) fails with "TypeError: unsubsc...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-11 11:20 EST by Callan Tham
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-11 19:37:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
sources file I used to install gpa using up2date (2.04 KB, text/plain)
2004-01-28 13:49 EST, Jef Spaleta
no flags Details

  None (edit)
Description Callan Tham 2003-12-11 11:20:41 EST
Description of problem:
Installing gpa with up2date fails with "TypeError: unsubscriptable
object" on Fedora Core 1.

Version-Release number of selected component (if applicable):
gpa-0.7.0-0.fdr.2.1.i386.rpm

How reproducible:
Just running "up2date gpa" triggers the error.

Steps to Reproduce:
1. Run "up2date gpa"
2. up2date fetches rpm headers
3. Process "explodes" while testing package sets/resolving dependencies.
4. Process dies with "TypeError: unsubscriptable object" message.
  
Actual results:
# up2date gpa

Fetching package list for channel: fedora-core-1...
[...]
Testing package set / solving RPM inter-dependencies...
exploded!
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 1188, in ?
    sys.exit(main() or 0)
  File "/usr/sbin/up2date", line 766, in main
    fullUpdate, dryRun=options.dry_run))
  File "/usr/sbin/up2date", line 1051, in batchRun
    batch.run()
  File "up2dateBatch.py", line 70, in run
  File "up2dateBatch.py", line 142, in __dryRun
  File "up2date.py", line 387, in dryRun
  File "depSolver.py", line 716, in solvedep
  File "depSolver.py", line 683, in process_deps
  File "depSolver.py", line 475, in __dependencies
  File "depSolver.py", line 93, in solveDep
  File
"/usr/share/rhn/up2date_client/repoBackends/genericSolveDep.py", line
40, in solveDep
    self.getSolutions(unknowns)
  File
"/usr/share/rhn/up2date_client/repoBackends/genericSolveDep.py", line
235, in getSolutions
    hdr = self.getHeader(pkg)
  File
"/usr/share/rhn/up2date_client/repoBackends/genericSolveDep.py", line
217, in getHeader
    progressCallback = progressCallback)
  File "rpcServer.py", line 110, in doCall
  File "repoDirector.py", line 31, in getHeader
  File "rpmSource.py", line 210, in getHeader
  File "/usr/share/rhn/up2date_client/repoBackends/yumRepo.py", line
104, in getHeader
    rpmSourceUtils.saveHeader(hdr)
  File "rpmSourceUtils.py", line 24, in saveHeader
TypeError: unsubscriptable object

Expected results:


Additional info:
Error occurred with RPM version 4.2.1, customized Fedora Core 1
install, running kernel 2.4.22-1.2129.nptl, up2date v4.1.16.

Following lines are active in /etc/sysconfig/rhn/sources:

yum fedora-core-1 http://fedora.redhat.com/releases/fedora-core-1
yum updates-released
http://fedora.redhat.com/updates/released/fedora-core-1
http://fedora.redhat.com/updates/testing/fedora-core-1
yum fedora-extras-1
http://download.fedora.us/fedora/fedora/1/i386/yum/stable
yum livna http://rpm.livna.org/fedora/1/i386/yum/stable

Please let me know if more info is needed.
Comment 1 Paul Nasrat 2003-12-11 12:19:41 EST
Is this possibly a duplicate of 99396

triage->duplicate #99396

Comment 2 Callan Tham 2003-12-11 13:12:39 EST
I've tried using the method described in Comment #3 in Bug 99396, but
it still doesn't work.

---
File "/usr/share/rhn/up2date_client/repoBackends/yumRepo.py", line
104, in getHeader
    rpmSourceUtils.saveHeader(hdr)
  File "rpmSourceUtils.py", line 24, in saveHeader
TypeError: unsubscriptable object
---

Same error as first reported. However, when used to update installed
components up2date works; I've just done an update on net-snmp and it
finished without a hitch.

I have also tried installing other packages eg w3m using up2date, but
it would die with the same error.
Comment 3 Jef Spaleta 2004-01-28 13:37:02 EST
I'm not sure this is a dup, since the earlier report deals with
up2date versions without yum repository ability. That being said, I
can't reproduce this issue by running up2date gpa on my fc1 install. It
worksforme. 

Can you try to clear out your /var/spool/up2date directory?



Comment 4 Jef Spaleta 2004-01-28 13:49:07 EST
Created attachment 97302 [details]
sources file I used to install gpa using up2date

This is attached as a reference, to confirm the problem is not a misconfigured
sources file. This sources file was the one i was using with i installed gpa
using 'up2date gpa'
Comment 5 Youssef Makki 2004-01-28 14:10:52 EST
Worksforme using sources mentioned in Comment #4.
I installed gpa using 'up2date gpa'.
Comment 6 Jef Spaleta 2004-02-11 19:37:10 EST
I'm closing this report as worksforme.
Since comment #5 confirms comment #4 source list is working,

Please, before ropening this bug, make sure you are using a known
working sources list. This could very well be a syntax error in the
original reporters config file. It would also be nice if the original
reporter would attach the non functional source file for review.

Note You need to log in before you can comment on or make changes to this bug.