Bug 1119199 - Failed to build from source package
Summary: Failed to build from source package
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: librsvg2
Version: 6.6
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: Matthias Clasen
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-14 09:06 UTC by Martin Simon
Modified: 2014-10-14 07:41 UTC (History)
2 users (show)

Fixed In Version: librsvg2-2.26.0-13.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-14 07:41:11 UTC


Attachments (Terms of Use)
rpmbuild --rebuild librsvg2-2.26.0-12.el6.src.rpm (149.32 KB, text/x-log)
2014-07-14 09:06 UTC, Martin Simon
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1554 normal SHIPPED_LIVE gtk2, gdk-pixbuf2, librsvg2, and libwmf bug fix and enhancement update 2014-10-14 01:27:57 UTC

Description Martin Simon 2014-07-14 09:06:04 UTC
Created attachment 917705 [details]
rpmbuild --rebuild librsvg2-2.26.0-12.el6.src.rpm

Description of problem:
The package failed to build from source rpm, problem with moz-plugin and/or linker paths, probably. This bug was found with TPS system.

Version-Release number of selected component (if applicable):
librsvg2-2.26.0-12.el6.src.rpm

How reproducible:
100%

Steps to Reproduce:
1. $ rpmbuild --rebuild librsvg2-2.26.0-12.el6.src.rpm (e.g. from brewweb)

Actual results:
Fail with following output:
....
libtool: compile:  gcc -DHAVE_CONFIG_H -I. -I.. -DXP_UNIX -I/usr/include/xulrunner-17.0.10 -DBINDIR=\"/usr/bin/\" -pthread -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -pthread -I/usr/include/gtk-2.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/pango-1.0 -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -MT moz-plugin.lo -MD -MP -MF .deps/moz-plugin.Tpo -c moz-plugin.c  -fPIC -DPIC -o .libs/moz-plugin.o
moz-plugin.c:42:19: error: npupp.h: No such file or directory
moz-plugin.c:79: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'mozilla_funcs'
moz-plugin.c: In function 'svg_plugin_newp':
moz-plugin.c:245: error: 'mozilla_funcs' undeclared (first use in this function)
moz-plugin.c:245: error: (Each undeclared identifier is reported only once
moz-plugin.c:245: error: for each function it appears in.)
moz-plugin.c:262: warning: implicit declaration of function 'strtol'
moz-plugin.c: In function 'svg_plugin_destroy':
moz-plugin.c:295: error: 'mozilla_funcs' undeclared (first use in this function)
moz-plugin.c: At top level:
moz-plugin.c:349: error: expected declaration specifiers or '...' before 'uint16'
moz-plugin.c: In function 'svg_plugin_new_stream':
moz-plugin.c:366: error: 'stype' undeclared (first use in this function)
moz-plugin.c: In function 'svg_plugin_destroy_stream':
moz-plugin.c:389: error: 'mozilla_funcs' undeclared (first use in this function)
moz-plugin.c: At top level:
moz-plugin.c:549: error: expected ')' before '*' token
make[2]: *** [moz-plugin.lo] Error 1
...

Expected results:
The build should be successful

Additional info:
The whole log is attached

Comment 1 Marek Kašík 2014-07-14 11:29:58 UTC
The package doesn't explicitly disables the building of the mozilla plugin. It builds fine in brew and mock. But since it blocks you from finishing the QA process and it is a trivial change, I'm giving this devel_ack+.

Comment 4 errata-xmlrpc 2014-10-14 07:41:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1554.html


Note You need to log in before you can comment on or make changes to this bug.