This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 111922 - Kernel fails to build on i686
Kernel fails to build on i686
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-11 12:15 EST by Dave Miles
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-16 09:52:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dave Miles 2003-12-11 12:15:42 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
At least Two problems currently prevent the Fedora core 1 kernel from 
building. Hardware platform is PII in HP Omnibook Xe2DB. I am using 
standard config for i686 from the configs directory having upgraded 
kernel source from up2date to 2129 version.

1) kernel/sched.c fails to compile reporting 'undefined reference to 
active_load_balance'. 

This is easily fixed by editing the code to move the offending line 
~217 outside the #ifdef, but seems to be a bit basic

2) Later a report of 'undefined reference to init_rootfs' is reported 
in function mnt_init

I realise I'm reporting two issues here, but there is a lot of 
discussion of this in a number of forums including some old 
references to similar problems on redhat versions. In several cases 
these were rejected as 'not a bug'. They definately are bugs, and I 
don't think I'm the only person experiencing them, so they should be 
either re-logged or re-opened.

Version-Release number of selected component (if applicable):
Kernel linux-2.4 ... 2129 nptl

How reproducible:
Always

Steps to Reproduce:
1. Build kernel using the regular i686 config file
2.
3.
    

Actual Results:  Errors as described above

Expected Results:  Kernel should build

Additional info:
Comment 1 Arjan van de Ven 2003-12-11 12:19:16 EST
did you start with make mrproper ?
Comment 2 Dave Miles 2003-12-11 12:30:05 EST
Sequence to build was

make clean
make mrproper
copy standard config file file from configs directory to .config
make xconfig (here I make no changes just save and exit - also have 
repeated whole sequence using 'make config' and 'make menuconfig')
make dep
make bzImage
Comment 3 Arjan van de Ven 2003-12-11 12:34:00 EST
make xconfig is broken; you need to do a make oldconfig after it...
Comment 4 Dave Miles 2003-12-12 07:05:26 EST
Ok have run make oldconfig after make xconfig and the build now works 
ok. Have a working kernel, although interestingly its not __exactly__ 
the same (size) as the distributed one. Are you aware whether the 
distributed kernel is made from the distributed configs or from some 
other config file ? ps. I used kernel-2.4.22-i686.config as the base 
for my build.

Suggest if you have a mechanism to make the 'missing' oldconfig step 
more widely known you use it, it will save a lot of 'bad mouthing' of 
Fedora thats currently flying around on the web.

Thanks for the help
Comment 5 Arjan van de Ven 2003-12-12 07:09:22 EST
we use that exact config (as you can see in the spec file). The size
difference can be due to the fact that the kernel builds the hostname
and date/time of build into itself (see the first line of dmesg) and
is then compressed, obviously different strings yield slightly
different compression results..
Comment 6 Dave Miles 2003-12-16 05:40:13 EST
Ok, I think that's it for now. Thanks again

Note You need to log in before you can comment on or make changes to this bug.