Bug 1119225 - [engine-setup] 'Execution of setup failed' message is odd if only nfs start failed
Summary: [engine-setup] 'Execution of setup failed' message is odd if only nfs start f...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Setup.Engine
Version: ---
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Simone Tiraboschi
QA Contact: Jiri Belka
URL:
Whiteboard: integration
Depends On: 1066959
Blocks: 1155425 1258133
TreeView+ depends on / blocked
 
Reported: 2014-07-14 10:16 UTC by Jiri Belka
Modified: 2015-11-27 07:48 UTC (History)
7 users (show)

Fixed In Version: ovirt-3.6.0-alpha1.2
Doc Type: Bug Fix
Doc Text:
Due to external conditions NFS could not properly be started and so the setup fails but everything is indeed in place. Concluding issuing a warning will be safe enough.
Clone Of:
: 1258133 (view as bug list)
Environment:
Last Closed: 2015-11-27 07:48:56 UTC
oVirt Team: ---
rule-engine: ovirt-3.6.0+
ylavi: planning_ack+
rule-engine: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 40653 master MERGED packaging: setup: printing just a warning on NFS restart issue Never

Description Jiri Belka 2014-07-14 10:16:37 UTC
Description of problem:
"Execution of setup failed" message is odd if only nfs start fails. In fact setup is done, only NFS got some issue.

I think it should state this more clearly:
- setup done
- but there were some issues!

I have no idea what happened, it was clear install... Anyway, the BZ is about message of failure from engine-setup.

~~~

[ INFO  ] Restarting nfs services
[ ERROR ] Failed to execute stage 'Closing up': Command '/sbin/service' failed to execute
[ INFO  ] Stage: Clean up
          Log file is located at /var/log/ovirt-engine/setup/ovirt-engine-setup-20140714115528-ytp8fx.log
[ INFO  ] Generating answer file '/var/lib/ovirt-engine/setup/answers/20140714115734-setup.conf'
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination
[ ERROR ] Execution of setup failed

--

2014-07-14 11:57:34 DEBUG otopi.plugins.otopi.services.rhel plugin.execute:866 execute-output: ('/sbin/initctl', 'status', 'nfs') stderr:
initctl: Unknown job: nfs

2014-07-14 11:57:34 DEBUG otopi.plugins.otopi.services.rhel plugin.executeRaw:785 execute: ('/sbin/service', 'nfs', 'start'), executable='None', cwd='None', env=None
2014-07-14 11:57:34 DEBUG otopi.plugins.otopi.services.rhel plugin.executeRaw:803 execute-result: ('/sbin/service', 'nfs', 'start'), rc=1
2014-07-14 11:57:34 DEBUG otopi.plugins.otopi.services.rhel plugin.execute:861 execute-output: ('/sbin/service', 'nfs', 'start') stdout:
Starting NFS services:  [  OK  ]
Starting NFS quotas: [  OK  ]
Starting NFS mountd: [  OK  ]
Starting NFS daemon: [FAILED]

2014-07-14 11:57:34 DEBUG otopi.plugins.otopi.services.rhel plugin.execute:866 execute-output: ('/sbin/service', 'nfs', 'start') stderr:


2014-07-14 11:57:34 DEBUG otopi.context context._executeMethod:152 method exception
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/otopi/context.py", line 142, in _executeMethod
    method['method']()
  File "/usr/share/ovirt-engine/setup/bin/../plugins/ovirt-engine-setup/ovirt-engine/system/nfs.py", line 276, in _closeup
    state=state,
  File "/usr/share/otopi/plugins/otopi/services/rhel.py", line 188, in state
    'start' if state else 'stop'
  File "/usr/share/otopi/plugins/otopi/services/rhel.py", line 96, in _executeServiceCommand
    raiseOnError=raiseOnError
  File "/usr/lib/python2.6/site-packages/otopi/plugin.py", line 871, in execute
    command=args[0],
RuntimeError: Command '/sbin/service' failed to execute
2014-07-14 11:57:34 ERROR otopi.context context._executeMethod:161 Failed to execute stage 'Closing up': Command '/sbin/service' failed to execute

--

[root@ovirt ~]# service nfs status
rpc.svcgssd is stopped
rpc.mountd (pid 32015) is running...
nfsd dead but subsys locked
rpc.rquotad (pid 32011) is running...

--

[root@ovirt ~]# service nfs restart
Shutting down NFS daemon:                                  [FAILED]
Shutting down NFS mountd:                                  [  OK  ]
Shutting down NFS quotas:                                  [  OK  ]
Shutting down NFS services:                                [  OK  ]
Starting NFS services:                                     [  OK  ]
Starting NFS quotas:                                       [  OK  ]
Starting NFS mountd:                                       [  OK  ]
Starting NFS daemon:                                       [  OK  ]
Starting RPC idmapd:                                       [  OK  ]

--

Jul 14 11:57:32 localhost kernel: ip_tables: (C) 2000-2006 Netfilter Core Team
Jul 14 11:57:34 localhost kernel: RPC: Registered named UNIX socket transport module.
Jul 14 11:57:34 localhost kernel: RPC: Registered udp transport module.
Jul 14 11:57:34 localhost kernel: RPC: Registered tcp transport module.
Jul 14 11:57:34 localhost kernel: RPC: Registered tcp NFSv4.1 backchannel transport module.
Jul 14 11:57:34 localhost kernel: Installing knfsd (copyright (C) 1996 okir@monad.swb.de).
Jul 14 11:57:34 localhost rpc.mountd[32015]: Version 1.2.3 starting
Jul 14 11:57:34 localhost kernel: lockd_up: makesock failed, error=-98
Jul 14 11:57:34 localhost kernel: nfsd: last server has exited, flushing export cache
Jul 14 11:57:34 localhost rpc.nfsd[32019]: error starting threads: errno 98 (Address already in use)
Jul 14 12:01:49 localhost ntpd[5672]: 0.0.0.0 0613 03 spike_detect +44.616753 s
Jul 14 12:04:54 localhost rpc.mountd[32015]: Caught signal 15, un-registering and exiting.
Jul 14 12:04:55 localhost rpc.mountd[32425]: Version 1.2.3 starting
Jul 14 12:04:55 localhost kernel: NFSD: Using /var/lib/nfs/v4recovery

~~~

Version-Release number of selected component (if applicable):
ovirt-engine-setup-3.5.0-0.0.master.20140629172257.git0b16ed7.el6.noarch

How reproducible:
???

Steps to Reproduce:
1. no idea, just happened
2.
3.

Actual results:
nfs issue caused appearance of a message which could make an admin think the whole setup failed

Expected results:
setup is done but something got wrong

Additional info:

Comment 1 Jiri Belka 2015-11-13 19:03:21 UTC
ok, rhevm-setup-3.6.0.3-0.1.el6.noarch

[ INFO  ] Restarting nfs services
[WARNING] Unable to start NFS service or its dependencies: Failed to start service 'rpcbind' Please check their configuration and manually restart
         
          --== SUMMARY ==--
         
[WARNING] Warning: Not enough memory is available on the host. Minimum requirement is 4096MB, and 16384MB is recommended.
          SSH fingerprint: 77:6b:90:63:06:95:eb:70:6c:fd:a0:c0:30:55:1b:ba
          Internal CA 88:6A:96:02:F8:55:E8:D2:15:52:07:16:2F:66:D7:CE:EF:6A:DB:2D
          Note! If you want to gather statistical information you can install Reports and/or DWH:
              http://10-34-60-185.rhev.lab.eng.brq.redhat.com:80/ovirt-engine/docs/manual/en_US/html/Installation_Guide/chap-History_and_Reports.html
          Web access is enabled at:
              http://10-34-60-185.rhev.lab.eng.brq.redhat.com:80/ovirt-engine
              https://10-34-60-185.rhev.lab.eng.brq.redhat.com:443/ovirt-engine
          Please use the user 'admin@internal' and password specified in order to login
         
          --== END OF SUMMARY ==--
         
[ INFO  ] Starting engine service
[ INFO  ] Restarting httpd
[ INFO  ] Restarting ovirt-vmconsole proxy service
[ INFO  ] Stage: Clean up
          Log file is located at /var/log/ovirt-engine/setup/ovirt-engine-setup-20151112180228-xusrdi.log
[ INFO  ] Generating answer file '/var/lib/ovirt-engine/setup/answers/20151112180518-setup.conf'
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination
[ INFO  ] Execution of setup completed successfully

Comment 2 Sandro Bonazzola 2015-11-27 07:48:56 UTC
Since oVirt 3.6.0 has been released, moving from verified to closed current release.


Note You need to log in before you can comment on or make changes to this bug.