Bug 1119227 - Retrieving a job fails with no error
Summary: Retrieving a job fails with no error
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: system-config-printer
Version: 7.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Tim Waugh
QA Contact: Radka Skvarilova
URL:
Whiteboard:
Depends On: 1119222
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-14 10:27 UTC by Tim Waugh
Modified: 2014-11-03 12:16 UTC (History)
5 users (show)

Fixed In Version: system-config-printer-1.4.1-17.el7
Doc Type: Bug Fix
Doc Text:
Attempting to retrieve a job had no effect. This was because the CUPS IPP attribute "document-count" was renamed "number-of-documents" but system-config-printer used the old name. When no such attribute was found for a job, it assumed no documents could be retrieved. The application now looks for a "number-of-documents" attribute.
Clone Of: 1119222
Environment:
Last Closed: 2014-11-03 12:16:16 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1794 normal SHIPPED_LIVE system-config-printer bug fix update 2014-11-03 17:16:05 UTC

Description Tim Waugh 2014-07-14 10:27:29 UTC
+++ This bug was initially created as a clone of Bug #1119222 +++

Description of problem:
In the job viewer, 'Retrieve' does nothing. The reason is that the CUPS 'document-count' attribute has changed name to 'number-of-documents'.

Version-Release number of selected component (if applicable):
system-config-printer-1.4.5-1.fc20

How reproducible:
100%

Steps to Reproduce:
1.cupsctl PreserveJobFiles=Yes
2.Print a job
3.Start system-config-printer
4.Right-click on printer and select 'View Print Queue'
5.Click on 'Show completed jobs'
6.Right-click on job and select 'Retrieve'

Actual results:
Nothing happens.

Expected results:
File dialog asking where to save job.

Upstream fix:
  https://git.fedorahosted.org/cgit/system-config-printer.git/commit/?h=1.4.x&id=f77d09d6305170e512af3695ff01ef5fc2bd168e

Comment 2 Radka Skvarilova 2014-09-04 13:34:00 UTC
Tryied on RHEL7 with system-config-printer-1.4.1-19.el7 and actual results were correct:
File dialog asking where to save job.

Comment 4 errata-xmlrpc 2014-11-03 12:16:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2014-1794.html


Note You need to log in before you can comment on or make changes to this bug.