Bug 1119233 - [Nagios] - Show y-axis values in percentage in the cluster utilization graph, the scale of the graph should not change as per utilization [NEEDINFO]
Summary: [Nagios] - Show y-axis values in percentage in the cluster utilization graph,...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: nagios-server-addons
Version: rhgs-3.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: RHGS 3.0.3
Assignee: Nishanth Thomas
QA Contact: RamaKasturi
URL:
Whiteboard:
: 1112589 (view as bug list)
Depends On:
Blocks: 1087818 1161558
TreeView+ depends on / blocked
 
Reported: 2014-07-14 10:44 UTC by RamaKasturi
Modified: 2015-05-13 17:41 UTC (History)
7 users (show)

Fixed In Version: nagios-server-addons-0.1.9-1.el6rhs
Doc Type: Bug Fix
Doc Text:
Previously, the graph for cluster utilization did not display values in percentage on the Y-axis. This happened because the plugin used the default template where the scale value of the graph was not fixed. With this fix, a specific template is implemented for the Nagios plugin.
Clone Of:
Environment:
Last Closed: 2015-01-15 13:49:04 UTC
Target Upstream Version:
psriniva: needinfo? (nthomas)


Attachments (Terms of Use)
cluster utilization graph screenshot (137.85 KB, image/png)
2014-07-14 10:45 UTC, RamaKasturi
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0039 normal SHIPPED_LIVE Red Hat Storage Console 3.0 enhancement and bug fix update #3 2015-01-15 18:46:40 UTC

Description RamaKasturi 2014-07-14 10:44:06 UTC
Description of problem:
The graph for cluster utilization should show values in percentage on the Y-axis. The scale of the graph changes based on the utilization. That should not happen. Warning and critical lines does not appear on the graph when the utilization does not cross critical or warning levels.

Version-Release number of selected component (if applicable):
gluster-nagios-addons-0.1.8-1.el6rhs.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Add a cluster as a service on one of the hosts being monitored.
2. Create data on the volume in that cluster.
3. Check the cluster utilization graph.

Actual results:
The values on the Y-axis do not have a unit associated. 
The scale on the Y-axis changes as the brick utilization changes.
Lines for warning and critical levels are not being displayed on the graph.

Expected results:
Show the Y-axis values in percentage. 
The scale on the Y-axis should not change with utilization.
warning and critical lines should be displayed on the graph even if the utilization is zero.

Additional info:

Comment 1 RamaKasturi 2014-07-14 10:45:11 UTC
Created attachment 917735 [details]
cluster utilization graph screenshot

Comment 7 Dusmant 2014-09-25 07:24:42 UTC
*** Bug 1112589 has been marked as a duplicate of this bug. ***

Comment 8 RamaKasturi 2014-11-19 09:19:21 UTC
verified and works fine with build nagios-server-addons-0.1.9-1.el6rhs.noarch.

With the fix in this build, cluster utilization graph Y-axis does not change with utilization.

scale on the y-axis is shown as % Usage.

warning and critical lines should be displayed on the graph when utilization is zero.

Comment 9 Pavithra 2014-12-24 09:06:21 UTC
Hi Nishanth,

Can you please review the edited doc text for technical accuracy and sign off?

Comment 11 errata-xmlrpc 2015-01-15 13:49:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0039.html


Note You need to log in before you can comment on or make changes to this bug.