Bug 111924 - Emacs menu configuration creates broken .emacs
Emacs menu configuration creates broken .emacs
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: emacs (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-11 12:40 EST by Braden McDaniel
Modified: 2007-04-18 13:00 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-13 22:33:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Braden McDaniel 2003-12-11 12:40:13 EST
Description of problem:
When customizing the default face, Emacs creates a broken .emacs.

Version-Release number of selected component (if applicable):
21.2-33

How reproducible:
Consistently.


Steps to Reproduce:
1. From the "Options" menu, go to "Customize Emacs", then "Specific
Face...". Enter "default".
2. Change the font family to "lucidatypewriter", and the size to "100".
3. Press the "Save for Future Sessions" button.
4. Exit and restart Emacs.
  
Actual results:
When loading .emacs on startup, Emacs complains:

  An error has occurred while loading `/home/bmcdaniel/.emacs':

  error: "Variable binding depth exceeds max-specpdl-size"


Expected results:
A working .emacs.

Additional info:
Comment 1 Jens Petersen 2004-01-13 21:29:19 EST
Presumably you mean RHL9, not FC1?

Could you please test this with Emacs 21.3?
Comment 2 Braden McDaniel 2004-01-13 22:33:07 EST
Presumably I did mean RH9. Now I'm running FC1 with Emacs 21.3, and I
cannot reproduce the problem.

Note You need to log in before you can comment on or make changes to this bug.