Bug 1119256 - [glusterd] glusterd crashed when it failed to create geo-rep status file.
Summary: [glusterd] glusterd crashed when it failed to create geo-rep status file.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: geo-replication
Version: pre-release
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Avra Sengupta
QA Contact:
URL:
Whiteboard:
Depends On: 1119223
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-14 11:39 UTC by Avra Sengupta
Modified: 2015-05-14 17:42 UTC (History)
6 users (show)

Fixed In Version: glusterfs-3.7.0
Doc Type: Bug Fix
Doc Text:
Clone Of: 1119223
Environment:
Last Closed: 2015-05-14 17:26:18 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2014-07-14 13:30:21 UTC
REVIEW: http://review.gluster.org/8307 (gluster: Fix the recursive goto outs in the source code.) posted (#1) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 2 Anand Avati 2014-07-15 09:43:11 UTC
REVIEW: http://review.gluster.org/8307 (gluster: Fix the recursive goto outs in the source code.) posted (#2) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 3 Anand Avati 2014-07-15 12:57:00 UTC
REVIEW: http://review.gluster.org/8307 (gluster: Fix the recursive goto outs in the source code.) posted (#3) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 4 Anand Avati 2014-07-18 13:35:22 UTC
REVIEW: http://review.gluster.org/8307 (gluster: Fix the recursive goto outs in the source code.) posted (#4) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 5 Anand Avati 2014-07-21 17:26:27 UTC
COMMIT: http://review.gluster.org/8307 committed in master by Krishnan Parthasarathi (kparthas@redhat.com) 
------
commit f6ddb4675c096dc81420ed84fb2a6fefa9fea563
Author: Avra Sengupta <asengupt@redhat.com>
Date:   Mon Jul 14 13:07:08 2014 +0000

    gluster: Fix the recursive goto outs in the source code.
    
    Added a script check_goto.pl, that when run from
    the source code root, will scan all .c files to match
    the following pattern:
    
    label:
            if (condition)
                goto label;
    
    On finding such a pattern the script will print the file name
    and the line number. There are certain cases where the above
    recursive pattern is intended. Hence adding those labels to
    ignore-labels. Thanks Vijaikumar Mallikarjuna for the perl
    script.
    
    Also fixed all such existing errors
    
    Change-Id: I1b821d0a8c296f16e40faff20bd029bdc880c2e9
    BUG: 1119256
    Signed-off-by: Vijaikumar Mallikarjuna <vmallika@redhat.com>
    Signed-off-by: Avra Sengupta <asengupt@redhat.com>
    Reviewed-on: http://review.gluster.org/8307
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
    Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>
    Tested-by: Krishnan Parthasarathi <kparthas@redhat.com>

Comment 6 Niels de Vos 2015-05-14 17:26:18 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 7 Niels de Vos 2015-05-14 17:35:28 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 8 Niels de Vos 2015-05-14 17:37:50 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 9 Niels de Vos 2015-05-14 17:42:41 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.