Bug 1119266 - libstatgrab-0.91 is available
Summary: libstatgrab-0.91 is available
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libstatgrab
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Christopher Meng
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1165059
Blocks: 839612 1163320 1180496
TreeView+ depends on / blocked
 
Reported: 2014-07-14 11:52 UTC by Upstream Release Monitoring
Modified: 2015-09-18 10:56 UTC (History)
10 users (show)

Fixed In Version: libstatgrab-0.91-1.fc24
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-09-16 12:27:34 UTC


Attachments (Terms of Use)
libstatgrab.spec update to 0.91 (7.14 KB, text/x-rpm-spec)
2015-08-03 15:16 UTC, Tim Orling
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1008491 None None None Never

Internal Links: 1008491

Description Upstream Release Monitoring 2014-07-14 11:52:01 UTC
Latest upstream release: 0.91
Current version/release in Fedora Rawhide: 0.17-6.fc21.2
URL: http://ftp.i-scream.org/pub/i-scream/libstatgrab/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring

Comment 1 Petr Šabata 2014-11-06 17:15:09 UTC
Ping?

Comment 2 Petr Pisar 2014-11-13 08:40:05 UTC
There was a packaged rebase to 0.90, but somebody reverted it:

commit 634063ccfcb3d8dfd9c64f667885647c6ab6ec36
Author: Oliver Falk <oliver@linux-kernel.at>
Date:   Mon Sep 30 09:42:42 2013 +0200

    * Downgrade - as in f20
[...]
 %changelog
+* Tue Sep 17 2013 Oliver Falk <oliver@linux-kernel.at> - 1:0.17-5.2
+- Fix requires (epoch)
+
+* Tue Sep 17 2013 Oliver Falk <oliver@linux-kernel.at> - 1:0.17-5.1
+- Fix BZ#1008491 - too many broken deps
+

Comment 3 Petr Pisar 2014-11-13 08:55:13 UTC
There are not much reverse dependencies:

# repoquery --whatrequires 'libstatgrab.so.6()(64bit)' --source | sort -uf
bwm-ng-0.6-16.fc22.src.rpm
libstatgrab-0.17-7.fc22.2.src.rpm
perl-Unix-Statgrab-0.04-23.1.fc22.src.rpm
player-3.0.2-37.fc21.src.rpm
pystatgrab-0.5-15.fc22.src.rpm
razorqt-0.5.2-21.fc22.src.rpm

Comment 4 Christopher Meng 2014-11-15 12:00:21 UTC
(In reply to Petr Pisar from comment #3)
> There are not much reverse dependencies:
> 
> # repoquery --whatrequires 'libstatgrab.so.6()(64bit)' --source | sort -uf
> bwm-ng-0.6-16.fc22.src.rpm
> libstatgrab-0.17-7.fc22.2.src.rpm
> perl-Unix-Statgrab-0.04-23.1.fc22.src.rpm
> player-3.0.2-37.fc21.src.rpm
> pystatgrab-0.5-15.fc22.src.rpm
> razorqt-0.5.2-21.fc22.src.rpm

The reason that I left it there is that bwm-ng is not usable if I update this to 0.91.

Some APIs have been rewritten. I need to port the bwm-ng or they will be retired. But there are users still so I can't do that.

I'm seeking time to fix the package, it's a bit tough now.

Comment 5 Tim Orling 2015-04-05 18:26:00 UTC
https://www.freshports.org/net-mgmt/bwm-ng/

Comment 6 Volker Gropp 2015-07-23 05:18:55 UTC
(In reply to Tim Orling from comment #5)
> https://www.freshports.org/net-mgmt/bwm-ng/

the patch is merge in upstream repository at https://github.com/vgropp/bwm-ng

Another option would be to remove libstatgrab dependency since its only optional for bwm-ng (configure --without-libstatgrab)

Comment 7 Sven Lankes 2015-07-23 06:39:28 UTC
(In reply to Christopher Meng from comment #4)

> The reason that I left it there is that bwm-ng is not usable if I update
> this to 0.91.
> 
> Some APIs have been rewritten. I need to port the bwm-ng or they will be
> retired. But there are users still so I can't do that.
> 
> I'm seeking time to fix the package, it's a bit tough now.

Can you create a scratch build of 0.91 for f23 or devel?

I'll then test the bwm-ng patch against this and if it works the upgrade can proceed for devel.

Comment 8 Christopher Meng 2015-07-23 08:10:06 UTC
Seemed the fix is so simple ;-) Can't believe that.

I will scratch a build when I have time, don't worry.

Comment 9 Tim Orling 2015-08-03 15:16:41 UTC
Created attachment 1058790 [details]
libstatgrab.spec update to 0.91

Comment 12 Christopher Meng 2015-08-20 04:27:18 UTC
(In reply to Tim Orling from comment #11)
> Git URL: https://fedorapeople.org/cgit/ttorling/public_git/libstatgrab.git/
> 
> Spec URL: https://ttorling.fedorapeople.org/libstatgrab/libstatgrab.spec
> 
> SRPM URL:
> https://ttorling.fedorapeople.org/libstatgrab/libstatgrab-0.91-1.fc24.2.src.
> rpm
> 
> koji: http://koji.fedoraproject.org/koji/taskinfo?taskID=10761736

Please do not upload sources to the git, I've uploaded on Tuesday.

I'm cleaning up the spec now, since the way it got packaged is a bit odd.

Also upstream of it is awkward, in order to support oldschool platforms they still wrongly handle the pkgconfig file.

Comment 13 Upstream Release Monitoring 2015-09-15 06:14:31 UTC
cicku's libstatgrab-0.91-1.fc24 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=685013

Comment 14 Fedora Update System 2015-09-15 07:12:50 UTC
libstatgrab-0.91-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15870

Comment 15 Fedora Update System 2015-09-15 16:50:32 UTC
libstatgrab-0.91-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update libstatgrab'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15870

Comment 16 Raphael Groner 2015-09-16 10:38:58 UTC
lxqt-panel has broken dependencies in the rawhide tree:
On x86_64:
	lxqt-panel-0.9.0-7.fc23.x86_64 requires libstatgrab.so.6()(64bit)
On i386:
	lxqt-panel-0.9.0-7.fc23.i686 requires libstatgrab.so.6
On armhfp:
	lxqt-panel-0.9.0-7.fc23.armv7hl requires libstatgrab.so.6
Please resolve this as soon as possible.

Comment 17 Christopher Meng 2015-09-16 10:51:13 UTC
(In reply to Raphael Groner from comment #16)
> lxqt-panel has broken dependencies in the rawhide tree:
> On x86_64:
> 	lxqt-panel-0.9.0-7.fc23.x86_64 requires libstatgrab.so.6()(64bit)
> On i386:
> 	lxqt-panel-0.9.0-7.fc23.i686 requires libstatgrab.so.6
> On armhfp:
> 	lxqt-panel-0.9.0-7.fc23.armv7hl requires libstatgrab.so.6
> Please resolve this as soon as possible.

Not my fault, they need to rebuild the packages. lxqt panel supports libstatgrab 0.90+.

Comment 18 Raphael Groner 2015-09-16 11:12:02 UTC
Anyways, you can not push to stable currently cause of Beta Freeze.
https://fedoraproject.org/wiki/QA:SOP_freeze_exception_bug_process

Comment 19 Christopher Meng 2015-09-16 12:26:27 UTC
(In reply to Raphael Groner from comment #18)
> Anyways, you can not push to stable currently cause of Beta Freeze.
> https://fedoraproject.org/wiki/QA:SOP_freeze_exception_bug_process

Did you mean f23? Well it's already been cancelled according to negative karma threshold.

I planned to push the update to f23 since some people need that, but fine with current state because it doesn't really matter too much.

Comment 20 Kevin Kofler 2015-09-18 10:56:21 UTC
It is YOUR responsibility to:
* announce soname bumps in your packages AND
* ensure dependent packages get rebuilt in a timely manner.

For stable releases (currently F21 and F22) and branched prereleases (currently F23), soname bumps:
* are discouraged by the packaging guidelines and should only be done if there is a good reason, which so far you failed to provide (please clarify "some people need that"),
* MUST be pushed as grouped updates containing both the library and rebuilds of ALL dependent packages (using a buildroot override) in one and the same update group.
You MUST NEVER push a soname bump of a library as a standalone update in Bodhi (unless nothing in Fedora depends on it, of course).


Note You need to log in before you can comment on or make changes to this bug.