Bug 1119273 - [Nagios] - When CTDB is configured and functioning, stopping ctdb service on a node displays the status of ctdb service as 'UNKNOWN' and status Information as 'CTDB not Configured [NEEDINFO]
Summary: [Nagios] - When CTDB is configured and functioning, stopping ctdb service on ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: nagios-server-addons
Version: rhgs-3.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: RHGS 3.1.0
Assignee: Timothy Asir
QA Contact: RamaKasturi
URL:
Whiteboard:
Depends On:
Blocks: 1202842
TreeView+ depends on / blocked
 
Reported: 2014-07-14 12:01 UTC by RamaKasturi
Modified: 2015-07-29 05:26 UTC (History)
11 users (show)

Fixed In Version: nagios-server-addons-0.2.0-1.el6rhs.noarch
Doc Type: Bug Fix
Doc Text:
Previously, when CTDB was configured and functioning, stopping ctdb service on a node displayed the status of ctdb service as 'UNKNOWN' and the status information was displayed as 'CTDB not Configured' instead of showing a proper critical error message. Due to this wrong error message, user might think that the CTDB is not configured. With this fix, this issue is resolved and correct error messages are displayed.
Clone Of:
Environment:
Last Closed: 2015-07-29 05:26:35 UTC
divya: needinfo? (tjeyasin)


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:1494 normal SHIPPED_LIVE Red Hat Gluster Storage Console 3.1 Enhancement and bug fixes 2015-07-29 09:24:02 UTC

Description RamaKasturi 2014-07-14 12:01:15 UTC
Description of problem:
When ctdb is configured and functioning proplery, stopping ctdb on one node in the cluster displays ctdb status as 'UNKNOWN' and status information as 'CTDB not Configured'

Version-Release number of selected component (if applicable):
nagios-server-addons-0.1.5-1.el6rhs.noarch

How reproducible:
Always

Steps to Reproduce:
1. Install nagios on RHS node.
2. Now setup ctdb.
3. Nagios displays ctdb status as 'OK' and status information as 'Node Status:OK'
4. Now stop ctdb on one node by running 'service ctdb stop'

Actual results:
CTDB service on that node displays status as 'UNKNOWN' and status information as 'CTDB not configured'

Expected results:
CTDB should display the status as 'CRITCAL' with status information as 'ctdb process is not running'

Additional info:

Comment 2 Sahina Bose 2014-09-26 08:20:49 UTC
The plugin returns UNKNOWN as it does not find a ctdb service running. 

There should be reliable way to know if ctdb is required to be running on the node and not running - in which case it can be marked as CRITICAL.

Is there some way to know if ctdb is required on the node?

Comment 3 Raghavendra Talur 2014-09-26 10:04:19 UTC
One way of determining if ctdb is supposed to be running is by checking
chkconfig ctdb
If the output shows that ctdb chkconfig is on, it is fairly sure that ctdb is supposed to be running, but currently it is not.

I remember having conversation with Timothy about this.
There were other associated cases too and he must have more info on it.

Comment 4 Timothy Asir 2014-10-13 08:09:44 UTC
CTDB will be considered as configured only if the chkconfig status is on.
This may be a limitation now, but currently there is no specific tool or
something available to check the configuration.

Currently the plugin will not proceed validation and will immediately
returns "CTDB not configured" with Unknown status when there is
no ctdbd process is running. But, it should also consider the
ctdb chkconfig status to reach out the possible state.

I hope the following validations can be added to improve the plugin's
CTDB status find.

if any process.CTDB is not running and ctdb chkconfig status is on:
   then return "CTDB stopped", appropriate status code (OK).

if any process.CTDB is not running and ctdb chkconfig status is off:
   then return "CTDB not configured", Unknown

Comment 5 Timothy Asir 2014-11-14 07:30:19 UTC
Patch sent to upstream: http://review.gluster.org/#/c/9124/

Comment 9 RamaKasturi 2015-05-29 06:02:25 UTC
please put the FIV for the bug.

Comment 10 RamaKasturi 2015-05-29 09:08:33 UTC
Verified and works fine with build nagios-server-addons-0.2.0-1.el6rhs.noarch.

When CTDB is not configured, CTDB service will be created and it will be shown with status as UNKNOWN with status information as "CTDB not configured"

When CTDB is stopped and chkconfig CTDB is on , CTDB status is shown as "CRITICAL" with status information as "CTDB process is not running".

When CTDB is on and chkconfig CTDB is on, CTDB status is shown as "RUNNING" with status information "CTDB process is running".

Comment 11 Divya 2015-07-27 09:09:04 UTC
Tim,

Please review and sign-off the edited doc text.

Comment 13 errata-xmlrpc 2015-07-29 05:26:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-1494.html


Note You need to log in before you can comment on or make changes to this bug.