Bug 1119275 - missing fedora-21 configs
Summary: missing fedora-21 configs
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: mock
Version: 20
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Suchý
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-14 12:04 UTC by Jan Kratochvil
Modified: 2014-07-23 06:53 UTC (History)
7 users (show)

Fixed In Version: mock-1.1.40
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-23 06:53:59 UTC


Attachments (Terms of Use)

Description Jan Kratochvil 2014-07-14 12:04:51 UTC
Fedora 21 has been branches and its trees exist.
But mock still does not provide its configs.

These mock missing configs happen after every Fedora branching.

Comment 1 Miroslav Suchý 2014-07-14 12:58:40 UTC
Added in:
* f465b51 (HEAD, origin/msuchy-work, msuchy-work) Change releasever to 22 for rawhide
* 8018a90 Add F21 configs

Contributed by Igor Gnatenko

Comment 2 Adam Williamson 2014-07-15 04:20:52 UTC
could this please be pushed out to all releases quickly? I've already seen a question about this on G+. it should really probably be on someone's TODO list for branch time, it seems like we have to file a bug report to get it done each time...

Comment 3 Jan Kratochvil 2014-07-22 15:53:45 UTC
Is it mock bug or Koji bug?  mock cfg already has gpgcheck=1 but the packages are not yet signed:

mock -r fedora-21-x86_64 --init
warning: /var/lib/mock/fedora-21-x86_64/root/var/cache/yum/fedora/packages/zip-3.0-11.fc21.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID 95a43f54: NOKEY
Importing GPG key 0x95A43F54:
 Userid     : "Fedora (21) <fedora@fedoraproject.org>"
 Fingerprint: 6596 b8fb abda 5227 a9c5 b59e 89ad 4e87 95a4 3f54
 From       : /etc/pki/mock/RPM-GPG-KEY-fedora-21-primary
Package libgcc-4.9.1-2.fc21.x86_64.rpm is not signed

mock -r fedora-21-i386 --init
warning: /var/lib/mock/fedora-21-i386/root/var/cache/yum/fedora/packages/cpio-2.11-29.fc21.i686.rpm: Header V3 RSA/SHA256 Signature, key ID 95a43f54: NOKEY
Importing GPG key 0x95A43F54:
 Userid     : "Fedora (21) <fedora@fedoraproject.org>"
 Fingerprint: 6596 b8fb abda 5227 a9c5 b59e 89ad 4e87 95a4 3f54
 From       : /etc/pki/mock/RPM-GPG-KEY-fedora-21-primary
Package openldap-2.4.39-10.fc21.i686.rpm is not signed

Comment 4 Adam Williamson 2014-07-22 20:52:33 UTC
mock bug, it shouldn't expect signatures until we switch to using Bodhi for F21 branch.

Comment 5 Miroslav Suchý 2014-07-23 06:53:59 UTC
mock-1.1.41 is in stable

The problem is with timing. You can temporary solve it by
  gpgcheck=0
in /etc/mock/fedora-21-*
If I fix this gpgcheck, then by the time we would cut next release, the packages would be already signed. So there is no sense to do something here.


Note You need to log in before you can comment on or make changes to this bug.