Bug 1119285 - [Admin Portal] Error while executing action: The notification event VDS_ACTIVATE_MANUAL_HA is unsupported.
Summary: [Admin Portal] Error while executing action: The notification event VDS_ACTIV...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-webadmin
Version: 3.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.5.0
Assignee: Jiri Moskovcak
QA Contact: Pavel Stehlik
URL:
Whiteboard: sla
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-14 12:35 UTC by Jiri Belka
Modified: 2016-02-10 19:42 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-17 12:21:38 UTC
oVirt Team: SLA


Attachments (Terms of Use)
sosreport-LogCollector-20140714143248.tar.xz (6.13 MB, application/x-xz)
2014-07-14 12:35 UTC, Jiri Belka
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 30680 master MERGED core: added missing events to event_map Never

Description Jiri Belka 2014-07-14 12:35:19 UTC
Created attachment 917781 [details]
sosreport-LogCollector-20140714143248.tar.xz

Description of problem:
Assigning whole parent 'General Hosts Events' for notification causes following error window:

~~~
Error while executing action: The notification event VDS_ACTIVATE_MANUAL_HA is unsupported.
~~~

~~~
2014-07-14 14:29:29,319 DEBUG [org.ovirt.engine.core.bll.AddEventSubscriptionCommand] (org.ovirt.thread.pool-8-thread-29) [1b27710] Found permission 00000003-0003-0003-0003-00000000007b for user when running AddEventSubscription, on System with id aaa00000-0000-0000-0000-123456789aaa
2014-07-14 14:29:29,325 WARN  [org.ovirt.engine.core.bll.AddEventSubscriptionCommand] (org.ovirt.thread.pool-8-thread-31) [f94dc19] CanDoAction of action AddEventSubscription failed. Reasons:$eventName VDS_ACTIVATE_MANUAL_HA,EN_UNSUPPORTED_NOTIFICATION_EVENT
~~~

FYI 'already subscribed' lines in engine.log are probably caused by Firefox caching issue (multiple instances opened), you can ignore it.

Version-Release number of selected component (if applicable):
ovirt-engine-webadmin-portal-3.5.0-0.0.master.20140629172257.git0b16ed7.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. assign whole parent 'General Hosts Events' for notification
2.
3.

Actual results:
Error while executing action: The notification event VDS_ACTIVATE_MANUAL_HA is unsupported.

Expected results:
???

Additional info:

Comment 1 Jiri Belka 2014-07-14 12:39:49 UTC
I got same for:

~~~
Error while executing action: The notification event CLUSTER_ALERT_HA_RESERVATION_DOWN is unsupported.
~~~

Please handle together, this one got caused by 'Cluster Events' parent. 'HA Reservation check has passed' got unselected in the subtree.

Comment 2 Jiri Belka 2014-07-14 12:40:23 UTC
2014-07-14 14:37:35,799 WARN  [org.ovirt.engine.core.bll.AddEventSubscriptionCommand] (org.ovirt.thread.pool-8-thread-49) [7f4dac3f] CanDoAction of action AddEventSubscription failed. Reasons:$eventName CLUSTER_ALERT_HA_RESERVATION_DOWN,EN_UNSUPPORTED_NOTIFICATION_EVENT

Comment 4 Mooli Tayer 2014-08-21 12:33:45 UTC
Such cases should not cause errors in the future.

We should render event_map as optional at AddEventSubscriptionCommand.

Exactly like it is at the Notification Service.

Comment 5 Sandro Bonazzola 2014-10-17 12:21:38 UTC
oVirt 3.5 has been released and should include the fix for this issue.


Note You need to log in before you can comment on or make changes to this bug.