Bug 1119297 - Add net-tools to @core group
Summary: Add net-tools to @core group
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: distribution   
(Show other bugs)
Version: 7.1
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: 7.1
Assignee: RHEL Product and Program Management
QA Contact: Release Test Team
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-14 13:09 UTC by Bryan Totty
Modified: 2019-03-06 00:13 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-04 11:05:43 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bryan Totty 2014-07-14 13:09:31 UTC
Description of problem:
No ifconfig command by default in Red Hat Enterprise Linux (RHEL) 7


Version-Release number of selected component (if applicable):
RHEL 7


How reproducible:
Always.

Steps to Reproduce:
1. $ ifconfig

Actual results:
# ifconfig
-bash: ifconfig: command not found

Expected results:
Admins/users should be able to use the "ifconfig" command by default if they so desire. The package net-tools should be installed by default with desktop and server installations.

Additional info:
I understand that the command and associated package was purposefully left out, but can we get reconsideration or an excellent description of why this decision was made?

We could take the systemd approach with the "service" and "chkconfig" commands where the user is prompted that their commands are rerouted or they are given some indication that the command is deprecated.

Where is the ifconfig command in Red Hat Enterprise Linux (RHEL) 7?
https://access.redhat.com/solutions/700593

Comment 2 Jiri Popelka 2014-07-14 16:16:30 UTC
(In reply to Bryan Totty from comment #0)
> The package net-tools should be installed by default with desktop
> and server installations.

Moving to distribution for the decision.
No idea about RHEL-7, but on Fedora the net-tools package should be in
'standard' group so it's in most non-minimal installs.

> Additional info:
> I understand that the command and associated package was purposefully left
> out, but can we get reconsideration or an excellent description of why this
> decision was made?

The main reason for moving net-tools out of default installation has been that it has some limitations, which can't be fixed anymore. See bug #444036, comment #8.

Also all system tools and services now use iproute instead of net-tools so no package pulls net-tools into default install. See bug #687920.

> We could take the systemd approach with the "service" and "chkconfig"
> commands where the user is prompted that their commands are rerouted or they
> are given some indication that the command is deprecated.

Forwarding net-tools' commands to iproute's is next to impossible as their syntax is very different. See bug #444036, comment #5

(In reply to Bryan Totty from comment #1)
> I had seen some beta bugs similar to this one,

I can't find any such bugs against net-tools or distribution.
Can you add exact numbers ?

> but the reason for opening this bug against the public
> release is because many customers are upset about this decision so we may
> want to reconsider. 

Yeah, notting was probably right with bug #444036, comment #7

Comment 3 Jiri Popelka 2014-07-14 16:39:01 UTC
(In reply to Jiri Popelka from comment #2)
> I can't find any such bugs against net-tools or distribution.

Now I see bug #1056494

Comment 9 Václav Pavlín 2014-07-22 15:22:58 UTC
Hi Bryan,

As stated before, net-tools are deprecated thus shouldn't be used unless necessary. Behaviour in RHEL 7 is the same as in Fedora - net-tools is missing from minimal install, but is in @base (~= @standard in Fedora) which is installed in all non-minimal configurations.

Feel free to pull PMs in discussion. I don't think it's a good idea to put net-tools in minimal install as iproute is documented in all RH guides and docs, but would consider doing that if PMs recommend it.

Regards,
Vaclav

Comment 10 Chris Brandstetter 2014-07-29 16:08:21 UTC
Vaclav, I would like to know where you got the idea that net-tools are depreciated?  It is under active development on their Git repository.   They are still under active development, used by every other distro out there, including Debian in case you wanted to bring up the 5 year old discussion, and used by many third party packages, example is the VMWare drivers installer.  It makes using RHEL 7 with third party apps or scripts in a cross distro environment a PITA.  It also means wasted time for new RHEL admins while they try and figure out where ipconfig went, and no not every one, in fact most, do not go through RHEL training before becoming an admin.  There are some newer tools, but looking at some of the discussions about them people have found the net-tools programs to produce better outcomes, ex ethtool and mii-tool.

I would like to know why Redhat has decided that making it more difficult for their user base is a wise decision.  

And as far as it being in other, larger installs, why exactly would I want to do anything but a minimal install on a small resource virtual server?

Comment 11 Jiri Popelka 2014-07-29 16:24:22 UTC
(In reply to Chris Brandstetter from comment #10)
> It is under active development on their Git repository.

I don't call that active development, it's been just bug-fixing.
I think I can say that because the log shows that I commited 44 patches upstream.
iproute2 has been under active development.

> I would like to know why Redhat has decided that making it more difficult
> for their user base is a wise decision.  

As I already stated in comment #2, net-tools (unlike iproute2) has limitations which can't be fixed anymore.
net-tools uses ioctl - obsolete kernel interface
iproute2 uses netlink - successor to ioctl (https://en.wikipedia.org/wiki/Ioctl#Netlink)

Comment 12 Václav Pavlín 2014-08-04 10:53:50 UTC
Hi Chris,

Deprecated means that it should be avoided. If there is a specific use case where it is not possible you can still install and use these tools - they are in RHEL repository. 

WRT what I wrote above, net-tools shouldn't be part of minimal install as it must contain as small as possible set of packages and having both iproute and net-tools there would be duplication.

I don't say "every RHEL Admin goes through training", but on the other hand every admin should probably read through guides which suggest to use iproute.

And talking about other distributions, please see link in Comment #8. 

I am changing summary to what I think this bug is about - adding net-tools to @core (i.e. Minimal Install) and as I am strictly against doing so, setting devel_ack-

Jirka, is there a possibility to add some wrappers as mentioned in link in Comment #8 ?

Comment 13 RHEL Product and Program Management 2014-08-04 11:05:43 UTC
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.

Comment 14 Jiri Popelka 2014-08-04 11:42:01 UTC
(In reply to Václav Pavlín from comment #12)
> Jirka, is there a possibility to add some wrappers as mentioned in link in
> Comment #8 ?

See comment #2 - "Forwarding net-tools' commands to iproute's is next to impossible as their syntax is very different. See bug #444036, comment #5"


Note You need to log in before you can comment on or make changes to this bug.