Bug 111932 - root privileges can be executed by non-root imposter - at least for up2date
Summary: root privileges can be executed by non-root imposter - at least for up2date
Status: CLOSED DUPLICATE of bug 112419
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: pam   
(Show other bugs)
Version: 9
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-12-11 18:35 UTC by Wolfram R. Jarisch
Modified: 2013-07-02 22:58 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-13 14:15:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Wolfram R. Jarisch 2003-12-11 18:35:19 UTC
Description of problem: "up2date -u" does not always request root
privileges when logged in with ssh. Time since last request for
"up2date -u" may matter (, 2 minutes?). BUT: running up2date -u,
logging out, logging back in (all with ssh within a minute) would
allow someone else (using same username and passwd) to run up2date. I
guess this should not be.


Version-Release number of selected component (if applicable):
RedHat 9.0

How reproducible: elapsed time may matter, otherwise 90+%


Steps to Reproduce:
1.login with ssh. run "up2date -u" (answer root passwd). logout.
2.login again with ssh (within a minute?)
3.run "up2date -u" ... do not get request for root passwd
  
Actual results: root passwd not always needed to do privileged work
                may be a problem in other settings as well?


Expected results: should request root privileges EVERY time


Additional info: will keep watching this

Comment 1 Adrian Likins 2003-12-11 19:43:05 UTC
up2date does no handling of aquiring root privs itself, thats
the userhelper/consolehelper utils from the "usermode" package
(and it sounds like in this case, the pam_timestamp setup).

reassigning to usermode

Comment 2 Matthew Miller 2004-04-07 03:26:12 UTC
Workaround: put "sudo -k" in your .bash_logout. That should clear the
timestamp.

Comment 3 Tomas Mraz 2005-09-13 14:15:54 UTC

*** This bug has been marked as a duplicate of 112419 ***


Note You need to log in before you can comment on or make changes to this bug.