Bug 1119328 - Remove libgfapi python example code from glusterfs source
Summary: Remove libgfapi python example code from glusterfs source
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: libgfapi
Version: 3.5.1
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact: Sudhir D
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-14 14:19 UTC by Humble Chirammal
Modified: 2015-05-14 17:42 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.7.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-14 17:26:19 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Humble Chirammal 2014-07-14 14:19:42 UTC
Description of problem:

libgfapi python example and related code is still present in glusterfs source and it invites confusion for end users. Currently libgfapi-python is evolving as a separate project and its available here https://github.com/gluster/libgfapi-python

Version-Release number of selected component (if applicable):

GlusterFs 3.5

How reproducible:

N/A

Steps to Reproduce:

N/A


Additional info:

http://review.gluster.org/#/c/8237/

Comment 1 Anand Avati 2014-07-15 11:34:14 UTC
REVIEW: http://review.gluster.org/8311 (Add build generated __init__.py to .gitignore) posted (#1) for review on master by Prashanth Pai (ppai@redhat.com)

Comment 2 Anand Avati 2014-07-16 04:57:36 UTC
REVIEW: http://review.gluster.org/8311 (Add build generated __init__.py to .gitignore) posted (#2) for review on master by Prashanth Pai (ppai@redhat.com)

Comment 3 Anand Avati 2014-08-27 05:19:32 UTC
REVIEW: http://review.gluster.org/8311 (Add build generated *.py[oc] to .gitignore) posted (#3) for review on master by Prashanth Pai (ppai@redhat.com)

Comment 4 Anand Avati 2014-08-27 16:54:58 UTC
COMMIT: http://review.gluster.org/8311 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit f56558224423e3af92aa08aa702dbc8cbdc0c55b
Author: Prashanth Pai <ppai@redhat.com>
Date:   Tue Jul 15 17:00:09 2014 +0530

    Add build generated *.py[oc] to .gitignore
    
    Related to:
    http://review.gluster.org/8237
    
    Change-Id: I8f888f0363c4358026ad17b2dc288014f7c51466
    BUG: 1119328
    Signed-off-by: Prashanth Pai <ppai@redhat.com>
    Reviewed-on: http://review.gluster.org/8311
    Reviewed-by: Humble Devassy Chirammal <humble.devassy@gmail.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>

Comment 6 Niels de Vos 2015-05-14 17:26:19 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 7 Niels de Vos 2015-05-14 17:35:28 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 8 Niels de Vos 2015-05-14 17:37:50 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 9 Niels de Vos 2015-05-14 17:42:41 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.