Bug 1119354 - Manual tasks cannot be executed: Could not find work item handler for Manual Task [NEEDINFO]
Summary: Manual tasks cannot be executed: Could not find work item handler for Manual ...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: JBoss BPMS Platform 6
Classification: Retired
Component: Business Central
Version: 6.0.2
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: ---
Assignee: Kris Verlaenen
QA Contact: Marián Macik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-14 15:14 UTC by Jiri Svitak
Modified: 2015-12-08 13:39 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-08 13:39:26 UTC
Type: Bug
mmacik: needinfo?


Attachments (Terms of Use)

Description Jiri Svitak 2014-07-14 15:14:11 UTC
To reproduce:
1.) Create simple Start->ManualTask->End process and save it.
2.) Build&deploy the project.
3.) Go to process definitions and start the process, you'll get:

Error
Process Instances failed to start: [project1.ManualTask1:3 - :2] -- Could not find work item handler for Manual Task

Expected behavior:
For the default designer pallette, all items should be easy to use out of the box. So for example DoNothingWorkItemHandler could be registered by default in the business central runtime session to prevent such error message.

My env:
BPMS 6.0.2.GA

Comment 1 Jiri Svitak 2014-07-14 15:38:39 UTC
Workaround and is to add this line

"Manual Task": new org.jbpm.process.instance.impl.demo.SystemOutWorkItemHandler()

to file business-central.war/WEB-INF/classes/META-INF/CustomWorkItemHandlers.conf

Possible solution could be implementation of a new handler, which would call just manager.completeWorkItem() operation without any additional outputs. DoNothingWorkItem handler calls nothing and just hangs the process, so it wouldn't be suitable as a solution.

Comment 4 Marián Macik 2015-12-07 14:28:53 UTC
Still happens in 6.2.0.GA. Should this be considered in next release or is it irrelevant and should be closed? Thanks.

Comment 5 Marián Macik 2015-12-08 13:39:26 UTC
After speaking with Maciej we agreed that there will always be some tasks which do not have default handler (e.g. manual task, email task). So I am closing it as not a bug.


Note You need to log in before you can comment on or make changes to this bug.