Bug 1119386 - when removing a user or project that the logged in user is a member of, you have to log out.
Summary: when removing a user or project that the logged in user is a member of, you h...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon
Version: 4.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: beta
: 8.0 (Liberty)
Assignee: Matthias Runge
QA Contact: Ido Ovadia
URL:
Whiteboard:
: 1186833 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-14 16:25 UTC by Chris Roberts
Modified: 2016-04-07 20:59 UTC (History)
7 users (show)

Fixed In Version: python-django-horizon-8.0.0-5.el7ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-07 20:59:10 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0603 normal SHIPPED_LIVE Red Hat OpenStack Platform 8 Enhancement Advisory 2016-04-08 00:53:53 UTC
OpenStack gerrit 142481 None None None Never
Launchpad 1252341 None None None Never

Description Chris Roberts 2014-07-14 16:25:59 UTC
Description of problem:
when removing a user or project that the logged in user is a member of, you have to log out, or even going back to your project will continue to throw up errors in horizon and not show instances etc.

How reproducible:


Steps to Reproduce:
1. logged in user is assigned to 2 projects, delete project from admin panel
2. go back to projects and see just your project (not deleted) 
3. get nothing but errors from horizon and unable to continue work in your project.

Actual results:
get nothing but errors from horizon and unable to continue work in your project.

Expected results:
to be able to go back to your project and continue work

Comment 2 Julie Pichon 2014-07-16 10:20:48 UTC
I could have sworn this was fixed but it doesn't look like it, adding a link to the upstream bug about it.

Comment 5 Matthias Runge 2015-02-11 10:24:35 UTC
*** Bug 1186833 has been marked as a duplicate of this bug. ***

Comment 6 Arthur Berezin 2015-02-11 10:27:30 UTC
Moving to OSP7 based on upstream progress.

Comment 13 Ido Ovadia 2016-01-25 16:39:16 UTC
Verified
========
python-django-horizon-8.0.0-10.el7ost.noarch
openstack-dashboard-8.0.0-10.el7ost.noarch

Comment 15 errata-xmlrpc 2016-04-07 20:59:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html


Note You need to log in before you can comment on or make changes to this bug.