Bug 111941 - yum with gpgcheck=1 installs rpms even though the gpg keys have not been imported yet
yum with gpgcheck=1 installs rpms even though the gpg keys have not been impo...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-11 15:08 EST by akopps
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-26 05:42:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description akopps 2003-12-11 15:08:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.4)
Gecko/20030703

Description of problem:
I have added gpgcheck=1 in /etc/yum.conf and accidentally run
"yum update" without importing the Fedora GPG key first. Surprisingly,
yum still downloaded and installed new rpms.

Version-Release number of selected component (if applicable):
yum-2.0.4-2

How reproducible:
Always

Steps to Reproduce:
1. Remove all GPG keys from rpm data base.
2. add gpgcheck=1 to the main section in yum.conf
3. Try installing or updating packages with yum
    

Actual Results:  The update/install actions are performed.

Expected Results:  Yum should treat it as an error since gpg keys have
not been imported yet.

Additional info:
Comment 1 Jeff Johnson 2004-01-26 05:42:00 EST
Why error? For example, the rpm CLI does not treat as error.

No matter what the missing key is reported to yum. Marked upstream,
as that is where any fix will be.

Note You need to log in before you can comment on or make changes to this bug.