Bug 1119456 - "SELinux is preventing /usr/sbin/lightdm from write access on the directory ."
Summary: "SELinux is preventing /usr/sbin/lightdm from write access on the directory ."
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-14 20:04 UTC by Peter H. Jones
Modified: 2014-07-15 22:44 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-15 22:44:13 UTC


Attachments (Terms of Use)
SETroubleshoot output (3.70 KB, text/plain)
2014-07-14 20:04 UTC, Peter H. Jones
no flags Details
Xorg.0.log (24.23 KB, text/plain)
2014-07-14 20:06 UTC, Peter H. Jones
no flags Details

Description Peter H. Jones 2014-07-14 20:04:33 UTC
Created attachment 917981 [details]
SETroubleshoot output

Description of problem:
SELinux alert

Version-Release number of selected component (if applicable):
lightdm-1.8.8-1.fc20.i686

How reproducible:
Sporadic

Actual results:
SELinux alert

Expected results:
No alert

Additional info:

$ ps -flwwp 968 gives
"F S UID        PID  PPID  C PRI  NI ADDR SZ WCHAN  STIME TTY          TIME CMD
4 S jones      968   922  0  80   0 -  1335 wait   15:40 ?        00:00:00 /bin/sh /etc/xdg/xfce4/xinitrc"

Comment 1 Peter H. Jones 2014-07-14 20:06:33 UTC
Created attachment 917982 [details]
Xorg.0.log

Comment 2 Peter H. Jones 2014-07-15 02:20:35 UTC
It's happening on every start up when I log in .

Comment 3 Daniel Walsh 2014-07-15 22:44:13 UTC
THis is showing a file without a label.  It looks like the jones directory has no labels.  Probably was added from a system without SELinux.

You can simply add labels by running 

restorecon -R -v /home


Note You need to log in before you can comment on or make changes to this bug.