Bug 1119485 - Pacemaker restarts httpd repeatedly
Summary: Pacemaker restarts httpd repeatedly
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-foreman-installer
Version: Foreman (RHEL 6)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ga
: Installer
Assignee: John Eckersberg
QA Contact: Leonid Natapov
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-14 21:28 UTC by John Eckersberg
Modified: 2014-08-21 18:05 UTC (History)
6 users (show)

Fixed In Version: openstack-foreman-installer-2.0.15-1.el6ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-21 18:05:26 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1090 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Enhancement Advisory 2014-08-22 15:28:08 UTC

Description John Eckersberg 2014-07-14 21:28:45 UTC
I am hitting bug 1111747 with httpd.  We need to update the pacemaker monitor to have a start_delay setting like we did with rabbitmq and galera.

Example log snippet:

Jul 14 21:24:39 525400abfecb.example.org systemd[1]: Reloading.
Jul 14 21:24:39 525400abfecb.example.org systemd[1]: Starting The Apache HTTP Server...
Jul 14 21:24:39 525400abfecb.example.org crmd[12519]: notice: process_lrm_event: LRM operation httpd_start_0 (call=4581, rc=0, cib-update=4151, confirmed=true) ok
Jul 14 21:24:39 525400abfecb.example.org crmd[12519]: notice: process_lrm_event: LRM operation httpd_monitor_30000 (call=4582, rc=7, cib-update=4152, confirmed=false) not running
Jul 14 21:24:39 525400abfecb.example.org Filesystem(fs-nfs)[23834]: INFO: Running stop for 192.168.200.1 on /nfs
Jul 14 21:24:39 525400abfecb.example.org attrd[12517]: notice: attrd_cs_dispatch: Update relayed from 52540084e1f6.example.org
Jul 14 21:24:39 525400abfecb.example.org attrd[12517]: notice: attrd_trigger_update: Sending flush op to all hosts for: fail-count-httpd (987)
Jul 14 21:24:39 525400abfecb.example.org attrd[12517]: notice: attrd_perform_update: Sent update 31396: fail-count-httpd=987
Jul 14 21:24:39 525400abfecb.example.org attrd[12517]: notice: attrd_cs_dispatch: Update relayed from 52540084e1f6.example.org
Jul 14 21:24:39 525400abfecb.example.org attrd[12517]: notice: attrd_trigger_update: Sending flush op to all hosts for: last-failure-httpd (1405373078)
Jul 14 21:24:39 525400abfecb.example.org attrd[12517]: notice: attrd_perform_update: Sent update 31398: last-failure-httpd=1405373078
Jul 14 21:24:39 525400abfecb.example.org attrd[12517]: notice: attrd_cs_dispatch: Update relayed from 52540084e1f6.example.org
Jul 14 21:24:39 525400abfecb.example.org attrd[12517]: notice: attrd_trigger_update: Sending flush op to all hosts for: fail-count-httpd (988)
Jul 14 21:24:39 525400abfecb.example.org attrd[12517]: notice: attrd_perform_update: Sent update 31400: fail-count-httpd=988
Jul 14 21:24:39 525400abfecb.example.org attrd[12517]: notice: attrd_cs_dispatch: Update relayed from 52540084e1f6.example.org
Jul 14 21:24:39 525400abfecb.example.org attrd[12517]: notice: attrd_trigger_update: Sending flush op to all hosts for: last-failure-httpd (1405373078)
Jul 14 21:24:39 525400abfecb.example.org attrd[12517]: notice: attrd_perform_update: Sent update 31402: last-failure-httpd=1405373078
Jul 14 21:24:39 525400abfecb.example.org crmd[12519]: notice: process_lrm_event: LRM operation fs-nfs_stop_0 (call=4580, rc=0, cib-update=4153, confirmed=true) ok
Jul 14 21:24:39 525400abfecb.example.org systemd[1]: Reloading.
Jul 14 21:24:39 525400abfecb.example.org nova-novncproxy[14145]: 782: 192.168.200.206: new handler Process
Jul 14 21:24:39 525400abfecb.example.org systemd[1]: Starting The Apache HTTP Server...
Jul 14 21:24:39 525400abfecb.example.org systemd[1]: Stopping The Apache HTTP Server...
Jul 14 21:24:39 525400abfecb.example.org crmd[12519]: notice: process_lrm_event: LRM operation httpd_stop_0 (call=4585, rc=0, cib-update=4154, confirmed=true) ok

Comment 2 John Eckersberg 2014-07-15 14:17:28 UTC
https://github.com/redhat-openstack/astapor/pull/315

Comment 12 Leonid Natapov 2014-08-12 13:31:56 UTC
openstack-foreman-installer-2.0.18-1.el6ost.noarch

No restarts of httpd.

Comment 13 errata-xmlrpc 2014-08-21 18:05:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1090.html


Note You need to log in before you can comment on or make changes to this bug.