Bug 1119541 - [abrt] firewall-config: firewall-config:2069:onChangeZone:TypeError: 'NoneType' object is not iterable
Summary: [abrt] firewall-config: firewall-config:2069:onChangeZone:TypeError: 'NoneTyp...
Keywords:
Status: CLOSED DUPLICATE of bug 995760
Alias: None
Product: Fedora
Classification: Fedora
Component: firewalld
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:59fb5b566323f776500b4b00d73...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-15 03:08 UTC by redhatbugzilla
Modified: 2014-10-26 17:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-15 08:34:59 UTC


Attachments (Terms of Use)
File: backtrace (715 bytes, text/plain)
2014-07-15 03:08 UTC, redhatbugzilla
no flags Details
File: environ (1.92 KB, text/plain)
2014-07-15 03:08 UTC, redhatbugzilla
no flags Details

Description redhatbugzilla 2014-07-15 03:08:14 UTC
Description of problem:
Open Firewall Configuration

Version-Release number of selected component:
firewall-config-0.3.10-1.fc20

Additional info:
reporter:       libreport-2.2.2
cmdline:        /usr/bin/python -Es /usr/bin/firewall-config
executable:     /usr/bin/firewall-config
kernel:         3.15.4-200.fc20.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
firewall-config:2069:onChangeZone:TypeError: 'NoneType' object is not iterable

Traceback (most recent call last):
  File "/usr/bin/firewall-config", line 2069, in onChangeZone
    for item in sources:
TypeError: 'NoneType' object is not iterable

Local variables in innermost frame:
masquerade: False
name: 'time-exceeded'
_services: []
sources: None
default: False
_icmpblocks: []
interfaces: ['wlp3s0']
args: (<TreeSelection object at 0x2725b90 (GtkTreeSelection at 0x2229f50)>,)
iter: None
self: <__main__.FirewallConfig object at 0x2003410>
item: 'wlp3s0'
builtin: False
icmpblocks: []
rules: []
services: ['dhcpv6-client', 'ipp', 'ipp-client', 'mdns', 'ssh']
active_zone: 'public'
ports: []
forward_ports: []

Comment 1 redhatbugzilla 2014-07-15 03:08:16 UTC
Created attachment 918051 [details]
File: backtrace

Comment 2 redhatbugzilla 2014-07-15 03:08:17 UTC
Created attachment 918052 [details]
File: environ

Comment 3 Jiri Popelka 2014-07-15 08:34:59 UTC

*** This bug has been marked as a duplicate of bug 995760 ***


Note You need to log in before you can comment on or make changes to this bug.