Bug 111956 - load_drivers in hotplug.functions causes spurious "missing kernel or user mode driver" messages
load_drivers in hotplug.functions causes spurious "missing kernel or user mod...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hotplug (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-11 17:33 EST by David Baron
Modified: 2014-03-16 22:40 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2004_04_01-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-03 17:10:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to /etc/hotplug/hotplug.functions (1.09 KB, patch)
2003-12-11 17:34 EST, David Baron
no flags Details | Diff

  None (edit)
Description David Baron 2003-12-11 17:33:42 EST
Description of problem:  the load_drivers function in
/etc/hotplug/hotplug.functions causes "missing kernel or user mode
driver" messages that are in error, and confusing when trying to debug
problems (such as the fact that my USB serial adapter stopped
working).  It prints messages such as:

Dec 11 13:34:21 localhost usb.agent[24851]: missing kernel or user
mode driver usbcore

when I plug in my USB serial adapter.

The problem is that the function changed between RedHat 8/9 and Fedora
Core 1.  In previous versions there was more code inside the:

if ! lsmod ...
test, which included the code that prints that error message.  When
the code printing that error message was moved out of that if, the
initial value of LOADED was not changed as it should have been.

Version-Release number of selected component (if applicable):
hotplug-2003_08_05-1

How reproducible: every time
Comment 1 David Baron 2003-12-11 17:34:56 EST
Created attachment 96485 [details]
patch to /etc/hotplug/hotplug.functions

This patch seems correct to me and fixes the erroneous error messages.
Comment 2 Need Real Name 2004-01-29 00:52:33 EST
I was experiencing the same and the two-line change above solved the 
problem with no ill effects. Bravo, David! :>
Comment 3 Bill Nottingham 2004-05-03 17:10:19 EDT
2004_04_01 gets rid of the error message, and should fix the problem
as well.

Note You need to log in before you can comment on or make changes to this bug.