Bug 1119601 - ganesha.nfsd shows up in ps output even after pkill ganesha.nfsd was executed.
Summary: ganesha.nfsd shows up in ps output even after pkill ganesha.nfsd was executed.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: nfs-ganesha
Classification: Community
Component: MainNFSD
Version: 2.2
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Jiffin
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-15 06:40 UTC by Meghana
Modified: 2018-12-17 04:14 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-17 04:14:45 UTC


Attachments (Terms of Use)

Description Meghana 2014-07-15 06:40:19 UTC
Description of problem:
Use pkill ganesha.nfsd to kill nfs-ganesha. After a few seconds,
check rpcinfo -p to see if it lists any nfs services, none is seen.
showmount -e localhost shows,
clnt_create: RPC: Program not registered.
Although the services are unregistered and ports are clear,
ps aux | grep ganesha shows the process is still running,
root      3801  0.0  3.2 1461116 127664 ?      Sl   Jul13   0:07 /usr/local/bin/ganesha.nfsd -f nfs-ganesha.conf -L log.3 -N NIV_EVENT
I'd have to use kill -9 on the PID of nfs-ganesha to get the expected results.




Version-Release number of selected component (if applicable):
V2.1


How reproducible:
Intermittently

Steps to Reproduce:
1. Export a volume/directory using nfs-ganesha.
2. When the server has been active for a long time,
execute pkill ganesha.nfsd to kill it.
3. Check rpcinfo -p and showmount to see the status.
4. Execute ps aux | grep ganesha to see if ganesha is running.

Actual results:
1.[root@dhcp43-78 glusterfs-jun-11]# ps aux | grep ganesha
root      3801  0.0  3.5 1604532 138024 ?      Sl   Jul13   0:05 /usr/local/bin/ganesha.nfsd -f nfs-ganesha.conf -L log.3 -N NIV_EVENT
root     20321  0.0  0.0 103244   828 pts/0    S+   15:55   0:00 grep ganesha
2.pkill ganesha.nfsd
3.[root@dhcp43-78 glusterfs-jun-11]# rpcinfo -p
   program vers proto   port  service
    100000    4   tcp    111  portmapper
    100000    3   tcp    111  portmapper
    100000    2   tcp    111  portmapper
    100000    4   udp    111  portmapper
    100000    3   udp    111  portmapper
    100000    2   udp    111  portmapper
    100024    1   udp  56365  status
    100024    1   tcp  44862  status
4.[root@dhcp43-78 glusterfs-jun-11]# showmount -e localhost
clnt_create: RPC: Program not registered
5. [root@dhcp43-78 glusterfs-jun-11]# ps aux | grep ganesha
root      3801  0.0  3.2 1461116 127664 ?      Sl   Jul13   0:08 /usr/local/bin/ganesha.nfsd -f nfs-ganesha.conf -L log.3 -N NIV_EVENT
root     20342  0.0  0.0 103244   828 pts/0    S+   15:55   0:00 grep ganesha



Expected results:
ganesha.nfsd process shouldn't be listed on execution of ps command.


Additional info:

Comment 1 Soumya Koduri 2014-11-19 15:35:42 UTC
This bug is not yet root-caused and since there is no intention to fix this issue in 2.1, moving this bug to next version.


Note You need to log in before you can comment on or make changes to this bug.