Bug 1119641 - [SNAPSHOT]: error message for invalid snapshot status should be aligned with error messages of info and list
Summary: [SNAPSHOT]: error message for invalid snapshot status should be aligned with ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: cli
Version: 3.5.0
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Vijaikumar Mallikarjuna
QA Contact:
URL:
Whiteboard: SNAPSHOT
Depends On: 1117270
Blocks: 1145087
TreeView+ depends on / blocked
 
Reported: 2014-07-15 08:09 UTC by Vijaikumar Mallikarjuna
Modified: 2016-05-11 22:47 UTC (History)
7 users (show)

Fixed In Version: glusterfs-3.7.0
Doc Type: Bug Fix
Doc Text:
Clone Of: 1117270
: 1145087 (view as bug list)
Environment:
Last Closed: 2015-05-14 17:26:20 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2014-07-15 08:24:13 UTC
REVIEW: http://review.gluster.org/8309 (glusterd: Error msg for snapshot status for no existing snaps should be aligned with error messages of info and list) posted (#1) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 2 Anand Avati 2014-07-16 10:51:15 UTC
REVIEW: http://review.gluster.org/8309 (glusterd: Error msg for snapshot status for no existing snaps should be aligned with error messages of info and list) posted (#2) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 3 Anand Avati 2014-07-16 10:53:34 UTC
REVIEW: http://review.gluster.org/8309 (glusterd: Error msg for snapshot status for no existing snaps should be aligned with error messages of info and list) posted (#3) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 4 Anand Avati 2014-07-30 09:39:31 UTC
REVIEW: http://review.gluster.org/8309 (glusterd: Error msg for snapshot status for no existing snaps should be aligned with error messages of info and list) posted (#4) for review on master by Krishnan Parthasarathi (kparthas@redhat.com)

Comment 5 Anand Avati 2014-07-30 09:39:43 UTC
COMMIT: http://review.gluster.org/8309 committed in master by Krishnan Parthasarathi (kparthas@redhat.com) 
------
commit 9f41712d060a71259e4970b9c8b32771a6d1f2c7
Author: Vijaikumar M <vmallika@redhat.com>
Date:   Tue Jul 15 13:49:41 2014 +0530

    glusterd: Error msg for snapshot status for no existing snaps
    should be aligned with error messages of info and list
    
    When a snapshot operation like status, info, list
    performed on a non-existing snapshot.
    For Status error message is displayed as 'Snap not found'
    For List and Info error message is displayed as 'Snapshot does not exist'
    Have the consistant error message all the places
    
    Change-Id: I7b241217dba62fda844481731a6858e4ecb12897
    BUG: 1119641
    Signed-off-by: Vijaikumar M <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/8309
    Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>
    Tested-by: Krishnan Parthasarathi <kparthas@redhat.com>

Comment 6 Niels de Vos 2015-05-14 17:26:20 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 7 Niels de Vos 2015-05-14 17:35:29 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 8 Niels de Vos 2015-05-14 17:37:50 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 9 Niels de Vos 2015-05-14 17:42:41 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.