Bug 1119655 - runtime-name without suffix (.war) doesn't make the deployment available
Summary: runtime-name without suffix (.war) doesn't make the deployment available
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Web
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: ---
Assignee: Rémy Maucherat
QA Contact: Radim Hatlapatka
Russell Dickenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-15 08:46 UTC by Radim Hatlapatka
Modified: 2014-10-25 12:01 UTC (History)
2 users (show)

Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-15 13:33:16 UTC
Type: Bug


Attachments (Terms of Use)

Description Radim Hatlapatka 2014-07-15 08:46:40 UTC
Description of problem:
when deploying web application and specifying runtime-name without .war the deployment is deployed but the context doesn't become available.


How reproducible: always


Steps to Reproduce:
1. Start EAP
2. deploy war with specified runtime-name either via CLI or Web console
   * deploy --runtime-name=web-app web-app.war
   * deploy --runtime-name=web-app2.war web-app2.war
3. check logs and URL whether the deployment context is available 

Actual results:
It is available only in second case, not in the first case => (localhost:8080/web-app is not available and localhost:8080/web-app2 is)

Expected results:
Also in first case the deployment would be available.

Additional info:
If you think this belongs to another component, please update it.

Comment 1 Brian Stansberry 2014-07-15 13:33:16 UTC
Not a bug. The .war suffix is what triggers the deployment unit processors to recognize that the deployment is relevant. If you didn't use runtime-name and just did a simple deploy of a file with the .war suffix removed or changed you'd get the same behavior:

deploy web-app.xyz


Note You need to log in before you can comment on or make changes to this bug.