Bug 1119657 - Missing userdata and finish templates for Katello-compatible subscription management
Summary: Missing userdata and finish templates for Katello-compatible subscription man...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Registration
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Stephen Benjamin
QA Contact: Tazim Kolhar
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On: 1135973
Blocks: 1107690
TreeView+ depends on / blocked
 
Reported: 2014-07-15 08:48 UTC by Stephen Benjamin
Modified: 2016-04-22 16:17 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
When kickstarting an Openstack and image-based virtualization system, the system fails to register to the Satellite Server. Katello templates and userdata have been added to allow kickstarted image-based virtualization systems to register to the Satellite Server automatically.
Clone Of:
Environment:
Last Closed: 2014-11-13 22:28:45 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1857 normal SHIPPED_LIVE Red Hat Satellite 6 server bug fix update 2014-11-14 03:28:23 UTC
Foreman Issue Tracker 6609 None None None 2016-04-22 16:17:50 UTC

Description Stephen Benjamin 2014-07-15 08:48:30 UTC
Description of problem:
Katello provides kickstarts but does not provide userdata and finish templates for use with OpenStack and image-based virtaulization (vmware, libvirt, etc).

Version-Release number of selected component (if applicable):
6.0.3 beta

How reproducible:
Always

Steps to Reproduce:
1. Attempt to provision a cloud-init enabled openstack instance or image-based libvirt instance
2. Machine should be registered to Katello via subscription manager

Actual results:
Machine isn't registered

Expected results:
Machine is registered

Comment 1 Stephen Benjamin 2014-07-15 08:50:19 UTC
Created redmine issue http://projects.theforeman.org/issues/6609 from this bug

Comment 2 RHEL Product and Program Management 2014-07-15 08:54:14 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 4 Bryan Kearney 2014-07-29 16:03:54 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/6609 has been closed
-------------
Anonymous
Applied in changeset commit:katello|14cf77a0f80bcfdfb6b801a2b08b74f5f7b7d934.

Comment 6 Tazim Kolhar 2014-08-20 13:46:19 UTC
have sent request for verification steps tostbenjam@redhat.com

Comment 9 Stephen Benjamin 2014-08-21 11:59:37 UTC
Configure your OS to use the User Data and Finish templates, and then provision a host using one each of

1) a cloud-init enabled openstack image (uses User Data)

2) a non-cloud init enabled image using SSH authentication (uses Finish template)

Both should be registered to Satellite after cloud-init completes its run.

You should be able to use internal openstack resources to complete the testing.

Comment 12 Stephen Benjamin 2014-10-09 02:09:02 UTC
This code is in downstream, but needs BZ1135973 before it goes to ON_QA.

Comment 15 Tazim Kolhar 2014-11-06 13:42:12 UTC
Tried to verify the BZ :

but ended up adding  blocker : 

https://bugzilla.redhat.com/show_bug.cgi?id=1161140

# rpm -qa | grep foreman
ruby193-rubygem-foreman-redhat_access-0.0.4-2.el7sat.noarch
foreman-vmware-1.6.0.47-1.el7sat.noarch
rubygem-hammer_cli_foreman_tasks-0.0.3-3.el7sat.noarch
ruby193-rubygem-foreman_bootdisk-2.0.6-1.1.el7sat.noarch
foreman-1.6.0.47-1.el7sat.noarch
foreman-compute-1.6.0.47-1.el7sat.noarch
foreman-proxy-1.6.0.30-1.el7sat.noarch
ruby193-rubygem-foreman_hooks-0.3.5-2.el7sat.noarch
foreman-gce-1.6.0.47-1.el7sat.noarch
ruby193-rubygem-foreman_discovery-1.3.0-2.el7sat.noarch
rubygem-hammer_cli_foreman-0.1.1-16.el7sat.noarch
qe-sat6-rhel7.usersys.redhat.com-foreman-client-1.0-1.noarch
foreman-postgresql-1.6.0.47-1.el7sat.noarch
qe-sat6-rhel7.usersys.redhat.com-foreman-proxy-1.0-1.noarch
foreman-selinux-1.6.0.15-1.el7sat.noarch
foreman-libvirt-1.6.0.47-1.el7sat.noarch
ruby193-rubygem-foreman-tasks-0.6.9-1.1.el7sat.noarch
foreman-ovirt-1.6.0.47-1.el7sat.noarch

Comment 17 Corey Welton 2014-11-06 15:56:44 UTC
Targeting -> 6.0.7

Comment 21 errata-xmlrpc 2014-11-13 22:28:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2014:1857


Note You need to log in before you can comment on or make changes to this bug.