Bug 1119689 - Please split up ibus-handwrite into subpackages
Summary: Please split up ibus-handwrite into subpackages
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus-handwrite
Version: 22
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Peng Wu
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-15 09:58 UTC by Richard Hughes
Modified: 2015-04-22 06:49 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-22 06:49:30 UTC


Attachments (Terms of Use)

Description Richard Hughes 2014-07-15 09:58:05 UTC
A few weeks ago we produced this: https://docs.google.com/spreadsheets/d/1FBmdtwDH6WHaLBfy6yqYqjEd3IA5GBEDyh-65FVnDMc/edit?usp=sharing which is a list of all the applications and addons that share package names in Fedora

The problem is that users click "Remove" on "Japanese Handwriting" and then next time they open up software "Simplified Chinese Handwriting" is gone too so they click install on "Simplified Chinese Handwriting", and the "Japanese Handwriting" ibus addon appears installed too confused user then files a bug :)

Splitting things up into ibus-handwrite-zh and ibus-handwrite-ja with a -common package would fix things nicely. Thanks!

Comment 1 Richard Hughes 2014-07-28 17:17:31 UTC
Hi!

It would be really good if we could do this by F21-alpha, else we'll just have to temporarily block one of the two input methods. Thanks.

Richard

Comment 2 Peng Wu 2014-07-29 00:45:46 UTC
Maybe I need to split zinnia-tomoe also.

I will split the package later.

Comment 3 Peng Wu 2014-07-30 05:24:06 UTC
Split zinnia-tomoe and ibus-handwrite for rawhide/f21.

Please try it, thanks.

Comment 4 Jaroslav Reznik 2015-03-03 17:15:00 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22

Comment 5 Peng Wu 2015-04-22 06:49:30 UTC
Done, close bug.


Note You need to log in before you can comment on or make changes to this bug.