Bug 1119768 - SELinux is preventing accounts-daemon from 'open' accesses on the file /etc/passwd.
Summary: SELinux is preventing accounts-daemon from 'open' accesses on the file /etc/p...
Keywords:
Status: CLOSED DUPLICATE of bug 1119766
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:8f130e26345c8290e8d286c2e0e...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-15 13:12 UTC by Alexander Kurtakov
Modified: 2014-07-15 22:40 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-15 22:40:26 UTC


Attachments (Terms of Use)

Description Alexander Kurtakov 2014-07-15 13:12:04 UTC
Description of problem:
SELinux is preventing accounts-daemon from 'open' accesses on the file /etc/passwd.

*****  Plugin restorecon (99.5 confidence) suggests   ************************

If you want to fix the label. 
/etc/passwd default label should be passwd_file_t.
Then you can run restorecon.
Do
# /sbin/restorecon -v /etc/passwd

*****  Plugin catchall (1.49 confidence) suggests   **************************

If you believe that accounts-daemon should be allowed open access on the passwd file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep accounts-daemon /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:accountsd_t:s0
Target Context                system_u:object_r:tmpfs_t:s0
Target Objects                /etc/passwd [ file ]
Source                        accounts-daemon
Source Path                   accounts-daemon
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           setup-2.9.0-2.fc21.noarch
Policy RPM                    selinux-policy-3.13.1-63.fc21.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.16.0-0.rc4.git3.1.fc22.x86_64 #1
                              SMP Fri Jul 11 17:08:34 UTC 2014 x86_64 x86_64
Alert Count                   13
First Seen                    2014-07-15 15:32:31 EEST
Last Seen                     2014-07-15 16:09:18 EEST
Local ID                      7054f6ef-b123-4774-a59d-5158d79cb93d

Raw Audit Messages
type=AVC msg=audit(1405429758.250:515): avc:  denied  { open } for  pid=624 comm="accounts-daemon" path="/etc/passwd" dev="dm-0" ino=131589 scontext=system_u:system_r:accountsd_t:s0 tcontext=system_u:object_r:tmpfs_t:s0 tclass=file permissive=1


Hash: accounts-daemon,accountsd_t,tmpfs_t,file,open

Version-Release number of selected component:
selinux-policy-3.13.1-63.fc21.noarch

Additional info:
reporter:       libreport-2.2.3
hashmarkername: setroubleshoot
kernel:         3.16.0-0.rc4.git3.1.fc22.x86_64
type:           libreport

Comment 1 Daniel Walsh 2014-07-15 22:40:26 UTC

*** This bug has been marked as a duplicate of bug 1119766 ***


Note You need to log in before you can comment on or make changes to this bug.